2
$\begingroup$

Everytime I press D + LMB I see the pencil as cursor and the indication that I'm about to draw something, but every time I draw a line, the line disappears.

$\endgroup$
  • 1
    $\begingroup$ You need to give a lot more information...for example, what pencil (I am guessing grease pencil). $\endgroup$ – JakeD Nov 18 '16 at 18:59
  • $\begingroup$ Yes grease pencil. It was working until I switched to Object mode. $\endgroup$ – trafel Nov 18 '16 at 19:12
  • $\begingroup$ You mean you were in Grease Pencil mode? $\endgroup$ – JakeD Nov 18 '16 at 21:53
  • $\begingroup$ Are you using the RetopoFlow add-on by any chance? If so sometimes grease pencil won't work on an active object. You might have to export the object then reimport it. I was having the same issue and that was one fix. $\endgroup$ – Animatoring Jan 26 '17 at 18:29
  • $\begingroup$ If your object is set to x-ray mode, the grease pencil marks will vanish. $\endgroup$ – Griffin Mar 25 '17 at 18:17
2
$\begingroup$

Check to make sure you don't have the [Grease Pencil layers] and [Grease Pencil Colors] set to invisible (eye icon). I spent an hour trying to figure out why, but forgot that I turned them off.

For the new players: N to open the right hand menu. Uncollapse the ▼ ☑Grease Pencil and ▼Grease Pencil Colors Look to make sure the eyes are visible for both layers. Also try creating a new Grease Pencil layer and seeing if that fixes any issues.

$\endgroup$
1
$\begingroup$

Double check the opacity of the active layer. If it's set to zero, the created stroke won't be shown after drawing, by it will be visible when drawing

$\endgroup$
0
$\begingroup$

Be sure that X-Ray mode is disabled on the object you are drawing on. Having it on will make the object's geometry draw on top of any grease pencil strokes you make on it.

enter image description here

$\endgroup$
0
$\begingroup$

I met the same problem today.Maybe you pressed H accidentally. Go to the edit Mode and then try press Alt+H see if it works.

$\endgroup$
0
$\begingroup$

Check to see that you didn't accidentally go to a new frame in the dope sheet.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.