I'm currently modeling an aircraft and still learning a lot about modeling best practice and the general approach how to create a clean model mesh. As you can see from the image, there are two faces on the wing upper (also same on the lower) side that do not look right, even though the normal seem to be consistent. My guess is the problem may be caused by the intersection of the wing root at the fuselage, even though I do not know why this is creating a problem as the vertices are all connected cleanly.

.blend of the model

enter image description here <code>enter image description here</code> enter image description here

  • $\begingroup$ Can you upload your model? $\endgroup$
    – Fuboski
    Nov 18, 2016 at 11:19
  • $\begingroup$ Sure, updated the question $\endgroup$
    – wowpatrick
    Nov 18, 2016 at 11:27
  • $\begingroup$ @Mzidare shots the problem ;) that's why you have that shading problem $\endgroup$
    – Fuboski
    Nov 18, 2016 at 11:44

1 Answer 1


You probably created this faces after enabling smooth shading and they are not updated yet. Go to object mode, enable Flat shading and then Smooth shading again and this faces will start looking as they should.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .