8
$\begingroup$

This question already has an answer here:

Ive only been introduced to Blender yesterday and have been trawling through the tutorials and loving it, definitely a new fan, albeit still taking very small steps.

I exported a VRML from a GIS application (ArcScene). I have done little to the scene in Blender, apart from adding some material effects to the ground layer.

What I can't understand is why my final render has a lot of noise in it.

Can someone give me some pointers on how to get a better quality render? Is it something to do with the render settings or have I missed something on the import/configuration of the scene?

enter image description here enter image description here enter image description here

$\endgroup$

marked as duplicate by gandalf3, CharlesL, Qwertie, iKlsR Feb 4 '14 at 23:27

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ Interesting image you rendered, by the way. I like it. As my answer suggested below, you should probably boost your sample count up a bunch and put a few hours into rendering it because Cycles looks like a much better choice for your project than BI (Blender Internal) because of its photo-realistic lighting. $\endgroup$ – Keavon Feb 4 '14 at 23:31
4
$\begingroup$

Cycles is a raycast-based render engine. It shoots thousands of rays from the camera and bounces them off surfaces randomly to compute the lighting. In order to produce a less-noisy result, you may increase the samples of your render:

Samples

This boosts the number of times it shoots rays from the same camera pixels. Since a surface (unless it's a mirror) scatters light, each time a ray bounces off a surface it must go in a random direction. Additional samples help average out this result by bouncing it multiple times per pixel and blending the results.

However, in the end, your result will always be noisy to some degree. Boosting the samples is a good way to avoid this, though.

Another way to avoid noise is to change the rendering method to Blender Internal or a third party renderer:

Blender Render

This is not a raycast renderer, so it simulates lighting in a non-photo-realistic (NPR) way. However, please note that development for the Blender internal renderer has ceased and Blender is generally transitioning to Cycles.

If you are interested in learning more about how Cycles or raycast renderers work, please take a look at my question: Why Can't Cycles Cast 1 Ray per Image Pixel, Instead Renders Progressively to Infinity?

If you would like to learn why some areas of an image are more noisy than others, which may help you avoid especially noisy areas, see my other question: What is the Reason Cycles Creates Incorrectly Colored/Firefly Artifact Pixels?

$\endgroup$
4
$\begingroup$

Blender Internal

If you're using Blender Internal with Raytracing as your Gather mode, the following will work. Raytracing is realistic, but it requires a certain number of samples, otherwise it will be grainy.

In the World settings in the Gather section, change the samples to something like 10 or 12: enter image description here

Cycles

If you're using Cycles, you can turn up the render samples in the Render panel under sampling: enter image description here

$\endgroup$
  • 2
    $\begingroup$ Definitely Cycles, otherwise the 'Feature Set' and OSL setting won't be visible. $\endgroup$ – Mike Pan Feb 4 '14 at 17:40
  • $\begingroup$ @MikePan good catch. I expected to see a sampling panel and automatically assumed it was BI when I didn't. Edited the answer accordingly. $\endgroup$ – CharlesL Feb 4 '14 at 20:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.