1
$\begingroup$

Keep getting this error message amd would really appreciate your help.

enter image description here

Any idea what this means?

I've edited some of the original code, changed around some of the parameters such as changing the name of the objects. I don't know if that had an effect?

If it did/would, vaguely what can I do to ensure this error message doesn't keep propping up.

Any suggestions? Thanks.

$\endgroup$

closed as unclear what you're asking by cegaton, Duarte Farrajota Ramos, batFINGER, Ray Mairlot, Mr Zak Feb 21 '18 at 19:02

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ when exactly is this message popping up and which "original code" you changed - do you mean Blender original source code?? $\endgroup$ – Noidea Nov 15 '16 at 22:23
  • $\begingroup$ Hey, thanks. The message pops up whenever I run the game engine. I've downloaded some blender script off the internet, created new objects and deleted the original ones, but embedded them into the code. I think this is something to do with it as I was not having the problem prior to changing the objects. $\endgroup$ – Eli Nov 15 '16 at 22:28
  • $\begingroup$ I'm not even sure what "image", "file" and "action" refer to. I cannot see them in the addon script, and no object is called any of those names. I'm a fetus when it comes to scripting- I understand if this is somewhat infuriating. $\endgroup$ – Eli Nov 15 '16 at 22:30
  • 2
    $\begingroup$ Strongly suggest posting a link to (or) the source code somewhere. My guess is it's a print statement in said code. $\endgroup$ – batFINGER Nov 16 '16 at 10:20
  • $\begingroup$ @batFINGER thank you! I seem to have sorted it out now and ran into a new problem, haha :D $\endgroup$ – Eli Nov 17 '16 at 16:19
1
$\begingroup$

The blender system is structured with Area's 1 and Regions 2.

Area

The application window is always a rectangle on your desktop. It is divided up into a number of re-sizable areas. An area contains the workspace for a particular type of editor, like a 3D View Editor, or an Outliner.

Region

An area is divided into regions (a sort of placeholders). For example:

  • Header
  • Main
  • Tool Shelf
  • Properties
  • etc

Scripts can use these regions to (for example) add custom panels to a region.

Now the Error

The message Error, region type missing in - name is send to the console when a script wants to access a region in a area for temporary windows.

This used to happen when users open a user-prefs or render window (those are temporary screen and). And then start using it as a regular window (split it, change space types... etc). This was solved in 2015, but could still be possible when scripting.

$\endgroup$
  • $\begingroup$ Could you please provide a small sample script which produces this error? $\endgroup$ – batFINGER Feb 21 '18 at 8:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.