9
$\begingroup$

I know how to add the effect strip and transform to resize a given image. This works when I have a low res image that I want to enlarge. But when the image is too high of a resolution and I scale it down, the image is windowboxed. It's as though the render frame is being transformed and not the source image file.

the resulting windowbox

Is there a way around this besides modifying the image file in an external program e.g. GIMP?

Edit

To clarify - here is the image that's imported to show the missing pixels.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ I am not sure if I am understand what you want. Do you want to lower the resolution of a source clip without changing its dimension in the sequencer? $\endgroup$ – Mike Pan Feb 2 '14 at 23:09
  • $\begingroup$ I have a 3000x2000 image that I'd like to fit in a 1280x720 video by uniform scale and offset. $\endgroup$ – ubershmekel Feb 2 '14 at 23:33
  • $\begingroup$ Obviously it is cropped, whether intended or not. If you didn't crop it, then it may be in a metastrip, which has been scaled. I'm feeling that you also want to keep the aspect of the picture as it was, which is 4:3, right? $\endgroup$ – Leon Cheung Feb 3 '14 at 5:15
  • $\begingroup$ Yes, but we losing quality. What when we want to make the journey along a huge photo? $\endgroup$ – user18705 Oct 11 '15 at 15:31
  • $\begingroup$ There exists a bug for this: developer.blender.org/T42355 $\endgroup$ – mardy Aug 9 '16 at 7:22
7
$\begingroup$

When you add an image (or movie) to the VSE, Blender will stretch the image/movie to fit the current setting of the resolution (even if the aspect ratios don't match).

For example, I have some footage filmed at 1280x960 (from a GoPro). I do SHIFT+A>Movie. Then under Render tab, I set my resolution to be 640x480. The original footage will be scaled by a factor of 0.5 automatically.

enter image description here

(this is showing the entire frame that was filmed)

Now if I choose to further scale it by 0.5 by adding an effect strip and setting Scale to 0.5 in the N-menu,

enter image description here

then it will be scaled by an additional 50%.

enter image description here

EDIT: After importing the movie and setting to 640x480, say you wanted to change resolution from 640x480 to 640x400. This will cause distortion. Instead of having distortion, you want to omit 40 pixels from both the top an bottom of the 640x480 image.

You would first change the resolution to 640x400. But this would squeeze your image in the y-direction by a factor of 480/400 = 1.2. Therefore, with your Transform strip already added, you'd open the N-menu, make sure Uniform Scale is disabled and set Scale: Y to 1.2.

enter image description here

$\endgroup$
  • $\begingroup$ This doesn't solve my problem. I'd like to avoid the windowboxing. E.g. in your case - what if you wanted to render at 640x400 and you only wanted to crop out the bare minimum (80 pixels of height) to fill the movie screen and avoid distorting the video? $\endgroup$ – ubershmekel Feb 3 '14 at 1:03
  • $\begingroup$ I've edited my answer. Have I understood what you're trying to do correctly now? $\endgroup$ – Garrett Feb 3 '14 at 2:02
  • $\begingroup$ Thanks for working so hard on this. Indeed if I leave the default "Image Offset" unchecked I have the whole image to work with. Do you know that there's no way to do it without calculating the ratio disparity for every image I add to my project? In premiere I can decide the scale and offset of an image on the properties (effects) panel. In my current project the image is 4:3 and the video is 16:9 so I have to apply a Y scale of 1.3333333. $\endgroup$ – ubershmekel Feb 3 '14 at 3:23
  • $\begingroup$ What do you mean when you say that "you have the whole image to work with"? $\endgroup$ – Garrett Feb 3 '14 at 3:28
  • $\begingroup$ The original problem was that the image was being cropped to the render frame before the transform effect is applied. So when I scaled down using the transform effect I got windowboxing. When I untick image offset the entire image is in the render frame so the transform effect has access to all the original pixels, i.e. no uncalled for cropping occurs. $\endgroup$ – ubershmekel Feb 3 '14 at 4:33
8
$\begingroup$

When import image into VSE, it is true that the original aspect will be changed to match the scene resolution. To fix this, you can simply add another Transform strip to first Transform (NOT the picture strip itself).

So, basically one for Uniform scale, and another one for aspect ratio correction.

enter image description here

enter image description here

enter image description here

P.S.: When setting the second Transform scale, be sure to set the longest side to 1.000, which is X in this case.

$\endgroup$
  • $\begingroup$ This is the correct answer, and very nicely illustrated. Very helpful, thanks! $\endgroup$ – Mikkel Jan 24 '18 at 18:27
  • $\begingroup$ @Mikkel Glad it helps. Btw, thank you for the vote, with which my reputation is over 20k. :) $\endgroup$ – Leon Cheung Jan 25 '18 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.