1
$\begingroup$

My object is overlapping the other object in the viewport.
The smaller model in the 'back' is showing through the larger model. They both have mirror and subdiv modifiers on them.

Front view two objects in the viewport the rear one overlapping the other

Side view to show that the model is behind the larger one. two objects in the viewport

$\endgroup$
2
  • $\begingroup$ what is overlapping or wrong here? I must be missing something, but when I look at your pictures I dont see the problem. $\endgroup$
    – David
    Nov 12, 2016 at 22:51
  • $\begingroup$ Sorry - The smaller modell should be behind the other one - on the image at the top it should be covered by the top geometry - if that makes sense. $\endgroup$ Nov 13, 2016 at 0:13

2 Answers 2

3
$\begingroup$

Uncheck X-Ray in Object->Display

enter image description here

if not, could you add the blend file, so I can check it?

$\endgroup$
1
  • $\begingroup$ That's it! Thanks a lot - Don't know how I haven't thought about that first.. $\endgroup$ Nov 13, 2016 at 0:11
0
$\begingroup$

Yeah, I had the same issue where a mesh would appear to be in front of everything in Viewport only.

I found another fix for people with the same problem in Blender 3.5:

  1. Select Mesh that is behind and overlapping everything causing problems
  2. On the right side go to Properties > Object Properties > Viewport Display (Object Properties is the orange square icon)
  3. Uncheck "In Front"
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .