0
$\begingroup$

System: Ubuntu 15.10 (so I can use GPU in Cycles since my GPU isn't supported for anything newer)

Installation: Installed with my Steam account since it makes keeping updated versions of Blender easier.

Hi, I installed an add on and it didn't work the first time. I installed by going to properties and addons and then install by file, next I selected the zip file and it didn't show my addon was installed and nothing changed after I clicked on save.

So I restarted Blender, and it still didn't show so then I clicked install by file and selected the .py files in the folder after I extracted them.

Then Blender complained that multiple addons installed with the same name. Rather than trying to figure out which one installed to what location I just deleted the entire /scripts folder. Now when I start Blender it crashes immediately.

I tried to re-verify the files within Steam. That didn't work, then I tried downloading a Blender from it's website. It will launch from its' own installation.

I replaced the entirety of the Steam Blender folder with the new one I downloaded. It will not launch from within Steam, but if I launch it from the file browser it launches.

I clicked on reload default startup file. That should tell Blender to not install any mods that aren't default ones (pretty sure that's what I needed). I clicked save startup and then removed Blender from Steam and then re-downloaded.

After re-installation within Steam I checked the addons folder. It contains all the addons I previously had selected. After trying to launch it, it still will not launch from within Steam. I'm out of ideas.

Does anybody else have any?

$\endgroup$
  • $\begingroup$ When you launch Blender is there an error message or it just doens't launch? Which version of blender do you use? Did you try to install blender by downloading file from the blender foundation? $\endgroup$ – Dupond Nov 10 '16 at 9:47
1
$\begingroup$

When you say that you deleted the /scripts folder, what do you mean exactly? You should never delete the folder that is under the blender installation path, as that will mean Blender cannot start up (some scripts are essential).

When you add an add-on from File -> User Preferences, it will be copied to your local blender user directory. This is ~/.config/blender/[VERSION].

No matter where it is installed, Blender will be looking in ~/.config/blender/[VERSION] for add-ons, which might explain why they are still present even after you have purged the installation directory and reinstalled.

If you haven't already, try deleting ~/.config/blender/[VERSION] (if my memory serves, it would be sudo rm -r ~/.config/blender/[VERSION]). Then reinstall a fresh copy of Blender via your preferred mechanism (e.g. Steam).

[VERSION] should be 2.78 or whatever you are using.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.