10
$\begingroup$

During a rendering I had a voltage drop, my UPS didn't work properly (damn, but the battery is new!) so PC shut down. I was more or less quiet because I saved a minute before start rendering, but when try to load my saved file blender report an error never seen before:

Loading: "E:\path where is the file" failed: failed to read blend file "E:\again path where is located file": Missing DNA block

It is the same, if I try to upload file from my saved folder or I try to recover from autosave tmp folder, or if I try to recover last session or quit session.

The file is not empty, is 66mb

I can load any other blender file without problems.

Any idea? Did I lose the file?

$\endgroup$
5
  • $\begingroup$ Can you share your file? $\endgroup$
    – dr. Sybren
    Commented Dec 8, 2016 at 0:39
  • 1
    $\begingroup$ I ran into the same problem. Did you have a blend1 file? If you rename the file to .blend, you can open the file with the same data your previous file had. $\endgroup$ Commented Jan 26, 2017 at 2:35
  • $\begingroup$ Hi, thanks for your reply, but too late, I redo the entire scene, if will happen again I'll try to follow your advice. $\endgroup$
    – Francesco
    Commented Jan 27, 2017 at 17:48
  • $\begingroup$ I have the exact same problem, but I did try using the blend1 file, and it did not work. So I guess it doesn't always work. $\endgroup$
    – Nikolaj
    Commented Jun 19, 2017 at 11:22
  • $\begingroup$ i found that this method worked for me. Go to to file and recover last session $\endgroup$
    – seth
    Commented Jul 8, 2017 at 17:03

3 Answers 3

4
$\begingroup$

I found a solution if this happens. go to recovery and save the files again . Need some luck too :)

$\endgroup$
4
$\begingroup$

This video worked for me, especially the second tip about Fail-Safe Duplicates -> https://www.youtube.com/watch?v=A-ot0j8W2XE In short go to open file -> find your file -> click on the filter icon in the upper right corner -> enable Backup .blend Files -> open the file which ends with .blend1. This will load an automatically saved backup file which, in my case, doesn't contain the DNA block missing error

$\endgroup$
0
2
$\begingroup$

You may try to build a new blend file, and try to append the data of the old file into the new one. Under the new Blend file, press Shift+F1 (or go to file>append), then navigate to the folder where is your saved Blend file and enter that file. You will see that the blend file is like a well structured folder and there, you can retrieve all kind of things, such as objects, materials, node setups, etc.. What you choose to append, will be then inserted to the new Blend file. You may want to repeat the steps, until you appended all you want.

$\endgroup$
4
  • 1
    $\begingroup$ Thanks for your reply. Following your advice I found an empty directory, no folder with material or object, nothing. The file is not empty, said so because occupy 66mb $\endgroup$
    – Francesco
    Commented Nov 6, 2016 at 11:03
  • $\begingroup$ when you say empty directory are you talking about the OS's file directory, or the structure in the blend file? $\endgroup$
    – David
    Commented Nov 6, 2016 at 12:42
  • 2
    $\begingroup$ Thanks for your reply David. I mean the blender file structure, there is no folder at all, but the file is (like yesterday and this morning when I work on it) 66 mb $\endgroup$
    – Francesco
    Commented Nov 6, 2016 at 14:48
  • 2
    $\begingroup$ same here. When trying to append the file is empty. $\endgroup$ Commented Jul 24, 2017 at 11:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .