2
$\begingroup$

Applying a normal map to my mesh makes the render use almost only 2 shades of grey and creates very contrasting shadows Here is a render with normal map: enter image description here And here is one without: enter image description here enter image description here

$\endgroup$
2
$\begingroup$

First, you need to set the Image Texture node to Non-color Data type, and secondly you need to run it through Normal Map node as seen below:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Your answer helped, but I immediatly ran into another problem, the shades seem diiferent on pathces of the render, i have added a screenshot too my question. $\endgroup$ – Otto Nov 3 '16 at 19:00
  • 1
    $\begingroup$ When you click on the field, where it currently states UV Map, in the Normal Map node, do any other options instead of UV Map show? $\endgroup$ – Štefan Schindler Nov 3 '16 at 19:10
  • $\begingroup$ No Uv map is the only option, I think it could be something to do with flipped uv's, since the patches correspond with the uv islands, but I'm not sure. $\endgroup$ – Otto Nov 3 '16 at 19:30
  • $\begingroup$ One thing, where is the normal map from (did you baked it or did it come with the model) and why do you need it, because the model without it looks pretty detailed? $\endgroup$ – Štefan Schindler Nov 3 '16 at 20:00
  • $\begingroup$ I baked it, I want to add a little more detail, since the original mesh I sculpted gets too laggy when texturing, so I copied the mesh, lowered the subdivisions by one and baked the normal map onto it. $\endgroup$ – Otto Nov 3 '16 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.