1
$\begingroup$

So, I have tried a tutorial about building a medieval house and everything worked quite okay for me until I came to the point of applying textures. I didn't follow the tutorial there because i remembered doing it differently a few years ago. I got into it again quite well and applied almost all the textures to the faces BUT... in my 3D view it looks like this, well, like it is supposed to look. Somehow. enter image description here

And then when I look at it in rendered view, it shows that somehow only the stonewall texture got applied to some of the faces. enter image description here I tried activating the wooden frame around the house and apply the texture again but the suddenly all the textured faces from the second image were covered with the wooden texture. I put a new material, put a new texture, clicked on assign in the material window and everything, I just can't get it. Also, what is bothering me is that i can't seem to apply any texture to the main structure (the house itself). I would be glad if someone could to help me.


In 3D material view: The image corresponds to the preview but what is bothering me is that the whole structure is affected and i can't obviously have a different material for different parts of the structure. AND the UV editor shows the "right" texture for the selected face. enter image description here

In rendered view: It still looks the same like in the image above in my original question.

Texture view: Also still the same.

So, what did i do wrong?

By the way, here is the file:

$\endgroup$
8
  • 2
    $\begingroup$ I would suggest watching the 'applying textures' part that you skipped when watching the tutorial. $\endgroup$
    – Ezra
    Nov 2, 2016 at 16:08
  • $\begingroup$ Are you using Blender Internal or Cycles? $\endgroup$ Nov 2, 2016 at 17:05
  • $\begingroup$ I'm using blender render. And i checked the tutorial already. It was some weird stuff about exporting uv maps, editing them in a picture program and stuff like that... since i don't have a picture program it's quite pointless. and there was nothing about my problem either. $\endgroup$
    – Rilli33
    Nov 2, 2016 at 17:19
  • $\begingroup$ I just figured out that if i select for example the chimney and try to apply a texture/material to it, it applies it to the whole structure (while i*m in in 3D material view). $\endgroup$
    – Rilli33
    Nov 2, 2016 at 17:36
  • $\begingroup$ Please consider using blend-exchange.giantcowfilms.com At least give us screenshots :) $\endgroup$ Nov 2, 2016 at 17:45

1 Answer 1

2
$\begingroup$

Found the problem!

Some faces overlap and causes some rendering problems. Go into Edit Mode and move some of the faces away from its overlapping part.

Note: Since you didn't give me a texture to work with, I simply used my own...

Render Probs

Another solution: Remove Doubles (Press "w"), but this will make you have to unwrap some faces again.

Nice house by the way!

Another problem: The overlapping faces that are causing render problems isn't properly unwrapped:

UV probs

I'm assuming you know how to unwrap, so go ahead and do that!

P.S: Select everything in Edit Mode and press ctrl + n. This will recalculate the normals and make you feel more organised ;)

Happy Blending!

$\endgroup$
2
  • $\begingroup$ Cool, I'll try to do that. Thanks a lot! :) $\endgroup$
    – Rilli33
    Nov 3, 2016 at 14:03
  • $\begingroup$ No problem! If it was helpful, please upvote! $\endgroup$ Nov 3, 2016 at 16:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .