4
$\begingroup$

I know the title is a mouthful, but this is the problem:

I made a curve with 90 degree corners, like so:

enter image description here

I then beveled it, and this was the result:

enter image description here

As you can imagine, this isn't very pretty. I'm looking for something like this:

enter image description here

How can I achieve this look?

$\endgroup$
  • $\begingroup$ It looks like you have your curve handle type set to Vector. Change it Align and it may solve your problem. $\endgroup$ – Paul Gonet Nov 1 '16 at 16:33
  • $\begingroup$ Try turning up the iterations, that should help. $\endgroup$ – Cowcatcherer Nov 1 '16 at 16:34
  • $\begingroup$ No, the curve handle type does not fix this no matter what type. $\endgroup$ – Espen Sales Nov 1 '16 at 17:01
7
$\begingroup$

First make sure your Bezier Curve type is set to 2D (if you don't need a 3D curve that is), that will automatically reduce deformation on tight corners.

It is a known limitation of the current system and there is no way around it at time moment. This was planned to be improved as part of 2016 GSOC Bezier Curve Improvements, but never actually made it.

Secondly in edit mode make sure your Spline Type is set to Bezier, it seems to be set to Poly which doesn't allow curved segments.

Thirdly erase the corner vertex and, as Paul Gonet mentioned turn the two contiguous handles to Aligned. If you still need actual 3D curves this technique will also reduce deformation considerably.

Curve corner

Lastly if you need to bevel curves this frequently the Curve Fillet addon from the Blender Market may help and simplify things in the long run. Disclaimer: Its a commercial paid addon, I am not the author nor affiliated with it in any way, though I did purchase it and use it regularly

$\endgroup$
  • $\begingroup$ Thank you taking your time to answer. I ran into a problem right away, though: when I choose the "2D" option, my grid turns right is flattened in the X axis, not the Z axis, turning it into a stick... no matter how I change the orientation. Do you have any idea what causes this? thanks. $\endgroup$ – Espen Sales Nov 1 '16 at 20:30
  • $\begingroup$ No matter! I simply jumped over this first step. Feel free to investigate on the issue, though. Again, thanks for taking the time to answer my question. Very appreciated! $\endgroup$ – Espen Sales Nov 1 '16 at 20:42
  • $\begingroup$ When converting to a 2D curve the local Z axis coordinates are discarded, and only the local X and Y coordinates are kept. If you rotated your curve in object mode before this, and the local axis are no longer aligned with the global scene axis then your curve conversion may give unexpected results. Be sure to apply transforms (especially rotation) before converting to 2D $\endgroup$ – Duarte Farrajota Ramos Nov 1 '16 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.