1
$\begingroup$

Not sure what happend - GPU rendering worked fine before - but now I cannot get blender to GPU render, though rendered preview works(!), so it shouldn't be driver. I have an AMD card, cannot remember driver updates recently. Updated to latest after the issue happend and it didn't help.

Problem is not related to file - same thing in the new projects now.

Also it depends on the number of samples, below are the render results for 1, 2 and 3 samples respectively. On 50 samples it's like almost completely black.

1 Sample 2 Samples 3 Samples

Did anybody had similar issue? Is there a known solution?

$\endgroup$
2
  • 1
    $\begingroup$ How does it work on CPU ? Did you try checking if there is a setting that differs between preview and final render and isn't supported on AMD GPU ? $\endgroup$
    – Mr Zak
    Commented Oct 31, 2016 at 19:00
  • $\begingroup$ It works on CPU (slow as hell, but seems like I don't have a choise now). It worked previously (like a week ago), so everything should be supported. I didn't change my PC configuration or anything - it just happend some day... $\endgroup$
    – Anton K.
    Commented Oct 31, 2016 at 19:20

1 Answer 1

1
$\begingroup$

Ok, so I found (thanks to Mr Zak!) that one of the differences between preview and final render was a Motion Blur. Even though it is disabled in preview and I had it disabled in render settings, when I enabled it in render panel and everything works again!

Though I definately remember it working from default blender file (where I suppose it was disabled?)... and this is seems like a bug, but hey, we found a workaround!

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .