complete newbie to Blender here. I'm trying to get 3D models into a WorldWind application. I'm not doing anything fancy with them (yet), all I want for the moment is to get models showing up correctly in my application. I downloaded several models from Sketchup's 3D Warehouse. Some of them were in .kmz format, others in .dae. Using WorldWind's KMLViewer as an example, I am able to easily load up the .kmz files. I can also load in the .dae models like so--write a .kml file that contains several Placemarks, each of which links to the appropriate .dae file for the model. Zip that .kml up in a .kmz file with the linked .dae and image files, and then load that into my program.

My problem is this: all of the models have their meshes outlined on top of the materials/textures.

After some research, I thought that perhaps the normals were flipped, so I tried to fix that in Blender. I'm not sure how well I did that, because, upon export, I now only get the mesh showing up in my application. In Blender, everything renders just fine. I've tried a few different export to .dae techniques as well as trying to see if my .dae IMPORT into Blender was wrong. Seen here, here, here, here, and here. None of them have worked. My steps include: un-checking the "Sequencer" option in Properties, making sure that the "Include UV Textures" and "Include Material Textures" are selected before exporting, and ensuring that all the materials' filepaths are correct. Again, it's showing up perfectly in Blender's render view, just not when I export it.

1. How do I get the models to render correctly after downloading from 3D Warehouse? Preferably straight from the "box".

2. If the answer to (1) requires adjusting & re-exporting from Blender, what steps am I doing wrong?

If more clarification or details are necessary, please let me know, I'll be happy to provide. For reference, I'm running on a Linux computer. The graphics cards and drivers are all up to date.

** EDIT: I thought this was just a dae vs kmz original download difference. It's not. Whether I download a model as a .kmz file or a .dae file, they all show up in WorldWind inside out. If this is a problem with WorldWind and not a configuration of models, I can get this question migrated to the correct SE. **

As requested, here is the image showing the difference, I'll link the .dae files in a bit. The colored+outlined image is what loads from pre-Blender .dae file; in essence, what I downloaded from 3DWarehouse. The mesh-only image is what renders after I try to fix the outlines and re-export. Neither of those are correct, as the image should have no white outlines.

enter image description here

The model that I'm using is (this one here).

  • $\begingroup$ It seems to me that the model must have duplicated faces. In edit mode remove doubles $\endgroup$ – user1853 Nov 2 '16 at 14:15
  • $\begingroup$ @cegaton, thanks for the suggestion. I tried this (In edit mode -> ctrl+L -> W -> Remove Doubles) just now and it still renders perfectly in Blender but only shows the outlined mesh in WorldWind $\endgroup$ – Lumos Nov 2 '16 at 15:34
  • $\begingroup$ I have no idea of what World Wind is or how it works. Maybe ask I a support forum for that app $\endgroup$ – user1853 Nov 2 '16 at 15:35
  • $\begingroup$ @cegaton, I think this is a Blender problem (not 100% sure though...) because some .dae models do load correctly in the WorldWind application, but not all of them. $\endgroup$ – Lumos Nov 2 '16 at 15:49
  • 1
    $\begingroup$ please add more information to your question, images of the issue and consider uploading the file so that others might help you determine what the issue is. $\endgroup$ – user1853 Nov 2 '16 at 15:59

The problem you have, is with the model it self. I have downloaded that Voldemort model and imported to Blender as DAE. Changed to Blender Render, and set the viewport mode to Material. There I can see exactly your triangles as material. What WorldWind will show you is exactly what you have under Blender Render's viewport material. image1 if you rotate your model, you can notice that you have a non well structured model (you have planes and edges that intersect themselves)image2 To fix this model, you should retopology on him, and build a single object, after this, you will want to bake the texture of the old model to the new model. Exporting the retopologized model, you should have no problems loading it into any other software. You may consider to download/search 3D models in other sources, like this: http://tf3dm.com/3d-model/lord-voldemort-13066.html. Then you just need to add an armature/rig the model and deform it to the pose you want, and export as DAE, so your software might read it (this process will be really faster than retopology the model and correct it, and retexturing it).

  • 1
    $\begingroup$ PS. It's not Blender's fault. It's the original model that just looks good but was wrongly built. (non manifold edges, non manifold faces, non manifold vertices, etc) $\endgroup$ – MCunha Nov 3 '16 at 9:21
  • $\begingroup$ Thank you! I'm glad to know that it is the model itself that needs work. As I don't need this specific model, I'll find ones that don't exhibit this problem. I'll definitely try retopologizing this model once my application is complete. I'm curious as to why so many models that I got from 3Dwarehouse are like this. Bad luck perhaps? But that might be beyond this question. $\endgroup$ – Lumos Nov 3 '16 at 12:30
  • $\begingroup$ the problem is that users that upload to 3dwarehouse are commonly people giving the firts steps in 3D modelling, and usually building them in skecthup. Later, they discover to model in other software, and share models in OBJ files or other file type. And that's when they understand the issues related with previous methods that they were applying, and hopefully they start to correct it. $\endgroup$ – MCunha Nov 3 '16 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.