5
$\begingroup$

For best render performance and more free VRAM I installed Blender on an Ubuntu server without GUI.

I launched Blender from the command line using argument and all was OK, but after installing it uses CPU render for Cycles and I wanted to use GPU render.

Without GUI I do not understand how to switch to it and how I can set tile size of render region (to get the best performance).

I tried to replace userconfig.blend with GPU setting but Blender still renders using CPU.

I also tried to set global variation BLENDER_USER_CONFIG="path to userconfig.blend file with GPU setting, or to run Blender on Ubuntu desktop mounting Blender folder from Ubuntu server and blender still uses CPU.

Any ideas?

$\endgroup$
2
$\begingroup$

Whether to or to not use the GPU is a setting saved in the .blend file that you render. Under the "Render" tab in the "Properties" Panel, you can set which compute device the file will render with (CPU or GPU). Note: if you aren't editing on a computer with a valid GPU, then that setting will not appear as an option. If you save the .blend file with that setting, then the command line will render with whatever compute device you specified. (blender -b file.blend [[-args]]) Unfortunately, this cannot be set directly through the command line.

Blender Command Line Arguments List.

$\endgroup$
  • $\begingroup$ Does this mean that if I save a .blend file on a machine which only has OpenCL not CUDA, the Ubuntu server will render using OpenCL and there's no way to set it to use CUDA? $\endgroup$ – tomh Feb 6 at 10:47
  • $\begingroup$ @tomh See if this helps: blender.stackexchange.com/a/6952/26640 $\endgroup$ – Scott Milner Feb 6 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.