2
$\begingroup$

I'm creating a Map for Garry's Mod PropHunt but having some odd shadowing issues.

For example on the supports left and right of the trackbeds: My Scenes current state.Here you can see some odd shadowing at the supports.

Somehow one of the support array's duplicate has odd shadowing, aswell as one of the fence's.

Closer view on the odd shadowing

Rotation & Scale are applied and normals were recalculated, so nothing wrong there.

Do you have any ideas what's wrong there?

$\endgroup$
  • $\begingroup$ Well, the bridge consists of four different parts, all have their own array-modifier. <br> The trackbed - 208x256x64 (Arrayed many times along Y-Axis and one time along X-Axis to get a mirror like result) The sidewalks - 64x128x16 The fence - 4x128x70 The support - 64x16x48 Every obejct mentioned above is placed "at the beginning of the bridge" and is arrayed along Y-Axis to get this result. Furthermore they're all aligned to the grid and have no overlapping parts. Maybe that was not quite clear I have to admit. $\endgroup$ – Flause Oct 30 '16 at 19:52
  • $\begingroup$ So here is a better attempt. Why is the array-modifier screwing up one of its duplicates shadows when all others are fine? This happens with the fence on the other side too, but there the shadows are in the opposite direction. $\endgroup$ – Flause Oct 30 '16 at 19:58
  • $\begingroup$ That's why I asked what the arrayed mesh looks like to make sure if that's not a seam between arrays. Just in case enable Merge and First Last options in Array mod. And check if there aren't any meshes located in that place as this looks like z-fighting. This would be easier with .blend file; if you can share it then upload it here and add link in comments / edit the question. $\endgroup$ – Mr Zak Oct 30 '16 at 21:14
  • $\begingroup$ Okay, I found a solution now. Switching from GPU to CPU Rendering is fixing it. But does anyone know why GPU rendering is screwing up just one of the array's duplicate and how to fix that maybe? $\endgroup$ – Flause Oct 30 '16 at 21:52
  • $\begingroup$ That was because of GPU ? Well, good to know. Maybe try changing camera clipping values (to be sure), but I don't think there's already answer for that. Maybe you could file a bug. Also, do you use Motion Blur while rendering this scene ? $\endgroup$ – Mr Zak Oct 30 '16 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.