3
$\begingroup$

Suppose I have a flat surface that looks like a T-junction. There are at least three ways to do it:

  1. Single concave polygon
  2. Several convex polygons
  3. Several convex quads

The three ways

(note that the right polygon on the second image is not quad, as its left side contains 4 vertices)

The first way seems the most natural, as my surface remains a single entity. If I want to move it, I just select it all in one click and do it. The other ways require me to manually select all polygons that my surface is composed of. Not very convenient. Vertex groups alleviate it somewhat, but still.

(2) and (3) unwrap correctly. Unwrapping of (1), however, results in a very weird map: Unwrapping of concave polygon

Am I doing unwrapping wrong? Or Blender just not supposed to unwrap concave polygons correctly? Will I be fine if I stick to convex n-gons? Or I should avoid them, too, and use simple quads only?

http://chireiden.torlan.ru/blender-unwrapping.zip - here is zipped .blend file, just in case.

$\endgroup$
  • 1
    $\begingroup$ For ease of selecting a chopped up ngon, it might help to use Shift+Ctrl+Alt+F to select all linked planar faces. $\endgroup$ – gandalf3 Jan 29 '14 at 21:11
1
$\begingroup$

The normal for the plane seems to be the problem. If you recalculate the normal using Ctrl+Shift+N on your mesh, it seems to unwrap correctly.

You can also use Project from View in the UV unwrap options, that seems to work without doing any modification on the mesh.

enter image description here

$\endgroup$
  • $\begingroup$ Yeah, recalculating normals helps for some reason, but once I rotate the mesh several times, unwrapping may suddenly become weird again. And recalculating normals didn't help at all in my larger model. In fact, flipping them inside, to the wrong direction, made unwrapping correct. Hit and miss. I'd certainly prefer splitting my mesh into simpler polygons to doing random normal flipping (which doesn't work every time). Project from view works here, but my larger model is not flat, so unfortunately it isn't an option. $\endgroup$ – WGH Jan 29 '14 at 18:48
1
$\begingroup$

I can't say why, but if you rotate it 360° (so basically no change), it will unwrap correctly.

I also tried Remove Doubles, Remove Doubles UV, removed Only Faces + Make Edge / Face and Mesh.validate(), but none of them helped. Doubling the scale did not work either, but something like scale factor 2.5847 worked.

You can also use Smart UV Project, which works a bit differently but gives proper result (with different orientation however) without the above rotation hack.

$\endgroup$
  • $\begingroup$ Rotating it by arbitrary angles does change the unwrapping. But it seems completely random. Sometimes it's OK, sometimes it's just as bad but completely different. Smart UV project, as I understand, ignores seams, which means it'll take a lot of effort to arrange resulting map as I need. $\endgroup$ – WGH Jan 29 '14 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.