0
$\begingroup$

Blender is only utilizing 54% on every core of my CPU (as shown in TaskManager) when rendering in Cycles. How can I make it use 100%?

Can this be fixed within Blender or is it more of an OS/hardware-related issue?

$\endgroup$
  • 1
    $\begingroup$ Using 54% doing what exactly? Blender can use more or less resources depending if it is a multi-tasked operation or not. Rendering for example is multi tasked and can use multiple processors, but certain mesh operations for example are not. Please edit your question and provide more information. $\endgroup$ – Duarte Farrajota Ramos Oct 25 '16 at 19:25
  • $\begingroup$ When rendering it can use 100%, but for almost all other things it uses just 1 or 2 cores (there are exceptions and some things are indeed multi-threaded). Compared with other 3D apps and not counting rendering I would put Blender in some bottom place performance-wise. Fortunately the performance is getting better and better with every release as things are being optimized by devs. $\endgroup$ – Jaroslav Jerryno Novotny Oct 25 '16 at 20:26
  • $\begingroup$ Please include OS information as well. On Linux 100% CPU means one CPU running at 100%, so the max of your machine would be 1000%. On Windows a single CPU at max would be 10%, with the entire machine at max at 100%. Kind of makes a difference. $\endgroup$ – dr. Sybren Oct 26 '16 at 8:51
  • $\begingroup$ In Properties -> Render -> Performance, is "threads" set to "Auto-Detect"? Maybe try to set it to "fixed" and play with number of treads manually? $\endgroup$ – Highstaker Oct 26 '16 at 13:53
  • 1
    $\begingroup$ @TTTTTTa You would understand if you saw the revision history. Click on the edited by so and so...and look at the original. When it gets updated, there is nothing in BSE that alerts others of it, and those who voted it down don't come back. Meanwhile, if it got voted down before editing, it is not likely to be voted back up later by others just up voting it. Hope that helps to clarify :-) $\endgroup$ – JakeD Nov 1 '16 at 2:10
3
$\begingroup$

Try to changing the number of threads to the same amount of the CPU (in this case 10)?

enter image description here

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Shady Puck did remove the part of the question that say that it used 54% on every core so I whon't go test it. It do probebly work if it was on 100% on 5 threds and the other on 1% $\endgroup$ – Alfons Marklén Oct 27 '16 at 7:31
  • $\begingroup$ I read the original question. regardless, you should try this solution anyway. $\endgroup$ – 10 Replies Oct 27 '16 at 10:17
1
$\begingroup$

Check max CPU usage in windows advance power options. In there set the maximum CPU usage to 100.

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ This is not an answer regarding Blender's side of the problem...the other answer is far better as this is just an OS specific, yet general with regard to various applications. Even though this may have fixed your problem (and the other didn't) answering this way makes your question off topic. $\endgroup$ – JakeD Oct 31 '16 at 14:25
  • $\begingroup$ The other is a better answer if it wasn't for the even CPU distribution. If anyone did poste something that would have removed a nother bottleneck would I accept to make it the answer. $\endgroup$ – Alfons Marklén Oct 31 '16 at 19:34
  • $\begingroup$ I edited your question to try to make this more reasonable. Please review/accept my edit if you are comfortable with it. The primary reason it was voted down AFAIK is because it was about specific hardware which is against BSE rules (that's at least why I voted it down). If you accept the edit, I'll change my vote accordingly. $\endgroup$ – JakeD Nov 1 '16 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.