2
$\begingroup$

I am trying to set up a mix of live footage and 3d rendering, but I keep failing in obtaining a realistic reflection layer.

My workflow is to have a ground plane that is totally white, a white sky, and five the plane some degree of reflection (here in the screenshot it is 1.0, but it's only to show the problem, I know it's not realistic this way). Then i multiply the reflection layer with the result of movieclip+foreground, but I keep having this annoying border around the plane.

How can I get rid of it?enter image description here

$\endgroup$
2
$\begingroup$

AFAIK, a Dilate/Erode node is commonly used to fix such issue.

Becides, it seems that you set the robot Layer as Mask layer for the reflect RenderLayer, which caused part of the plane was masked as transparent. Try untoggle that in RenderLayer setting, or add a new RenderLayer to get an expected alpha.

$\endgroup$
  • $\begingroup$ Hi @Leon, I've already tried that node but it seems to "erode" also the reflection itself, as they were some sort of semi-transparent alpha. Maybe I've got the connection of the nodes wrong? $\endgroup$ – Cranio Jan 28 '14 at 13:10
  • $\begingroup$ @Cranio I've updated my answer. $\endgroup$ – Leon Cheung Jan 28 '14 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.