2
$\begingroup$

There is a column of 20 "default cubes" on the plane static mesh (there is no any gaps between cubes and plane; cubes are precisely align by X and Y axes; plane and cubes are not rotated). Each cube is "rigid body" and has "box" collision bounds, all other settings are default (from Blender installation). After BGE starts, each cube has tiny movement, and the whole column becomes curved. 21-blocks column cannot stay at all.

With "Physics -> Damping -> Translation" option = 1.0 cubes and column keeps stability, but acquire unnatural behavior (not falling duging bumping by sphere).

Is there any way to create stable column with rigid bodies (it stays upright and keeps natural physics)?

editor and game look

$\endgroup$
  • 1
    $\begingroup$ You could start them deactivated if you use the rigid body physics in the 3D view, but I don't think you can do this in the BGE. Other than that, all I can think of is increasing the Substeps in Properties > World > Physics. $\endgroup$ – gandalf3 Jan 28 '14 at 0:01
  • $\begingroup$ I think you just need to increase the mass. Try a value of 2 or 3 and see if it works. $\endgroup$ – elclanrs Jan 30 '14 at 7:11
  • $\begingroup$ And try setting the gravity too. $\endgroup$ – elclanrs Jan 30 '14 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.