0
$\begingroup$

So this is my first time messing with blender, and models in general. I ripped a model as a temporary placeholder for my first game project in UE4. The likely cause of my problem is that it has a non-standard pose.

Im trying to add bones using rigify, and that has gone well enough but when I try to parent the metarig to the mesh with auomatic weights it gives me an error: "Bone heat weighting, cannot find solution for one or more bones."

I've tried goolging for solutions but neither of them work: set subsurf to on.

set X axis mirroring to on (tried on all possible entries of the scene list).

set a decimate modifier.

resetting rotation values.

remove doubles.

So I'd like someone to open up the file and see what the problem is because I think i've reached the point where I'm in over my head.

EDIT I figured there was an upload file option but I can't seem to find it. I've uploaded my file to dropbox instead: https://dl.dropboxusercontent.com/u/28736905/Pizzabella%20v1.42%20-%20metarig%20rotation%20reset%20in%20pose%20mode%20with%20ALT%2BG%20and%20ALT%2BR.blend

$\endgroup$
0
$\begingroup$

Your model has lots of issues:

select the mesh in object mode in the modifier stack remove the armature modifier; R Z 90 (rotate the model by 90 degrees around the Z axes); Ctrl A Apply rotation and scale; Select the MetaRig and M move it to a different layer. In edit mode A select all and remove doubles 0.1 mm (I removed something like 30.000 doubles). Back to object mode select the mesh, select the rig Ctrl P, choose the "With empty groups" option and go with manual weighting: paint weight or assign weights via the properties panel, vertex section, vertex groups tab.

The automatic weighting is a simple shortcut for simple meshes: they must be manifold, joined, without holes and seams; your mesh is maden of multiple spare parts and is far more complicated than what is manageable by the automatic algorithm.

$\endgroup$
  • $\begingroup$ Does the complexity of the model mean that I can't automatically assign weights at all? Because when I do so nothing of the model is moving. I'm afraid this won't change when I weight paint it manually. $\endgroup$ – DarkWave0 Oct 23 '16 at 12:12
  • $\begingroup$ In order to have automatic weights to work, you'll have to join all different parts of your mash (a pain). It's absolutely normal that nothing moves in this second option, as actually no vertex is weighted to no bone. As you start to paint it will start to work! $\endgroup$ – josh sanfelici Oct 23 '16 at 12:19
  • $\begingroup$ The weird thing is that I have another version of the model without the crossed arm pose and it will move the model even if I do automatic weights. I can't use that version because I can't seem to get the textures to show. But the point is that with that version it does work, so why doesn't it work with the version I posted above? $\endgroup$ – DarkWave0 Oct 23 '16 at 12:44
  • $\begingroup$ Another thing that confond the automatic feature is overlapping geometry, maybe the cross hand pose leads the fingers surface go underneath the skin surface, or something like that. Anyway I doubt that the automatic feature reached to weight all those spare parts. $\endgroup$ – josh sanfelici Oct 23 '16 at 13:01
  • $\begingroup$ For some reason model consisted of multiple copies of each part. Some of these parts are moveable by a metarig, and others are not. In the example I asked the question about I removed all copies except 1 for each part, which is why it couldn't move. I'd like to know why some parts are not moveable by metarig because as far as I know there is not reason they shouldn't be. $\endgroup$ – DarkWave0 Oct 26 '16 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.