2
$\begingroup$

I messing around with a scene where smoke blasts into a room from a tube in the wall.

The scene works out fine. I have set the domain to adaptive domain.

The only problem i have now is that the adaptive domain casts shadow on the room.

I have added a screenshot of the scene and a screenshot of the node setup for the domain.

Any clues on how to avoid that ?

scene

nodesetup

blend file

]

$\endgroup$
5
  • 1
    $\begingroup$ Based on pictures I'm guessing that the non-smoke areas still have some density, and that could probably be fixed by clipping the low density areas. I cannot, however test that without a file. could you please upload one here blend-exchange.giantcowfilms.com? $\endgroup$ Oct 22, 2016 at 22:28
  • $\begingroup$ ofc and thx alot, i have uploaded the file here <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=2132" /> $\endgroup$ Oct 22, 2016 at 22:31
  • $\begingroup$ Finished the test, didn't appear to fix it :/ $\endgroup$ Oct 22, 2016 at 23:29
  • $\begingroup$ oh well thx for trying anyways.. hope someone else has an idea how to fix that shadow $\endgroup$ Oct 23, 2016 at 0:04
  • $\begingroup$ solution for now is to make the domain the same size as the room.. its not perfekt and baking takes forever, but i cant figure out how to solve the shadow casting from the adaptive domain. $\endgroup$ Oct 23, 2016 at 20:27

3 Answers 3

2
$\begingroup$

select your domain, under properties panel go to object--> cycles settings--> deactivate shadow deactivate_cycles_shadow

$\endgroup$
2
  • $\begingroup$ ohh i will give that a try thx alot :-) $\endgroup$ Oct 27, 2016 at 8:05
  • $\begingroup$ At least, I've tried with your data and it seemed to work $\endgroup$
    – MCunha
    Oct 27, 2016 at 8:30
2
$\begingroup$

I know it´s quite a while since this Thread was active, but I had the same problem and no of all the solutions (and I searched a lot of other threads..) solved my problem. My Problem was.. the Render Settings!

Increase your "Light Path"-Settings, and it works. I hope I could help somebody, too.

Old Settings

New Settings

Viewport

$\endgroup$
0
$\begingroup$

Would something like this do? Vanilla 'OpenGL' render, using smoke images on multiple planes which can be coloured, scaled and slid out from the pipe to suit.

enter image description here

It only takes about 6 secs to render. (10 secs at full size) I d/loaded your file but as you mentioned, it takes an age to render in cycles,

$\endgroup$
1
  • $\begingroup$ thx for the suggestention , but no it has to be a real raytrace to get it more photorealistic as i am going to use it in a composite with a model (a real human model that is) $\endgroup$ Oct 27, 2016 at 8:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .