0
$\begingroup$

I'm trying to render layers suitable for output to photoshop for matte painting. I've made an example scene to illustrate the problem I'm having. The meshes composite correctly in blenders compositor, but when layered in photoshop the occluded parts are black instead of empty so they don't layer properly. How can I render layers so that they'll composite properly in photoshop? In the image below I have the layers across the top, and on the bottom left the compositor output as desired, and on the right the layers composited in photoshop. the goundplane, cube and sphere are rendered to separate layers as shown in the compositor and output through a File Output node as RGBA .png files.

enter image description here

They are saved as RGBA .png files and here's the compositor setup. I'll add a .blend file as soon as I can figure out how. enter image description here

$\endgroup$
  • $\begingroup$ What format are you using to export your layers? $\endgroup$ – user1853 Oct 21 '16 at 23:34
  • $\begingroup$ These are .png files saved from the render layer output $\endgroup$ – overcastcloudy Oct 21 '16 at 23:55
  • 1
    $\begingroup$ did you save as RGBA? Please edit your question and add more information on the procedure and settings you used to save the images. $\endgroup$ – user1853 Oct 22 '16 at 1:09
  • $\begingroup$ Do you actually mean the black part on the sphere? $\endgroup$ – metaphor_set Oct 22 '16 at 3:29
  • $\begingroup$ yes, I'm actually trying to layer together a complex environment set of meshes for matte painting. This is an example of the problems I'm having. The meshes are rendered like this and fit together well when composited in blender, but don't layer well in photoshop unless they are completely in front of or behind another mesh. if they have parts both in front and behind they come out as I've shown. I'm trying to see if I'm missing something and if there's a way to get the layers rendered such that they can behave properly in photoshop. $\endgroup$ – overcastcloudy Oct 22 '16 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.