0
$\begingroup$

Im importing and svg file and when i go to edit mode get some 1000's mesh and edges,etc. Is there a file to get a clean mesh. Image is attach object mode look fine but when turn to edit mode 1000's of mesh. Is there any other file format which we can get a clean mesh. enter image description here enter image description here

blender file

file disappear enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Mesh looks alright to me honestly, this is a fairly complicated pattern that requires a lot of polygons to represent. Might be simpler using ngons but the importer and simple conversion from curve to mesh is unlikely to generate these. $\endgroup$ – TLousky Oct 21 '16 at 16:58
  • $\begingroup$ To get that much detail you need many vertices. If you want to work with simpler geometry then do not convert your curves to mesh after importing SVGs $\endgroup$ – cegaton Oct 21 '16 at 23:31
  • $\begingroup$ a file attached problem im getting as soon as the remesh added it disappears $\endgroup$ – atek Oct 22 '16 at 6:05
  • 2
    $\begingroup$ To use the remesh modifier your mesh must have volume. You need to extrude all your geometry like in @Paul Gonet's example below, then the Remesh modifier will work. $\endgroup$ – TLousky Oct 22 '16 at 6:24
  • $\begingroup$ i have tried adding but its not working with my mesh can u plz try with my mesh $\endgroup$ – atek Oct 22 '16 at 7:12
3
$\begingroup$

There is no other file format that will guarantee a better mesh topology, unless you import as NURBS, but Blender can not import NURBS nor handle that kind of geometric complexity.

As TLousky mentions the results you are getting are totally normal and expected when converting a bezier curve into a mesh. However I would advise to not convert the SVG curve into a mesh, unless you specifically need to and only when you need to.

Keep it as a Bezier Curve object as long as possible, it's non destructive, will be easier to edit and maintain while being easily editable as a bezier curve handles.

Also have a look at my answer about cleanup techniques for bezier curve objects, useful both for keeping as curve or before converting to mesh for a cleaner topology.

Have in mind that converting Bezier Objects into meshes will always leave a mesh with uneven topology and lots of triangulated edges. You may later clean them up a bit by turning flat faces into NGons.

That won't improve topology nor benefit unwrapping or editing, but it may give a cleaner viewport.

enter image description here

$\endgroup$
  • $\begingroup$ a file attached problem im getting as soon as the remesh added it disappears $\endgroup$ – atek Oct 22 '16 at 6:05
  • $\begingroup$ and in ur image after u clicking the face what hot key u have press u got that normal and other options $\endgroup$ – atek Oct 22 '16 at 6:10
  • $\begingroup$ Press Shift +G in edit mode to bring up the Select Grouped menu $\endgroup$ – Duarte Farrajota Ramos Oct 22 '16 at 14:23
1
$\begingroup$

You may always improve the geometry after importing using the Remesh Modifier. enter image description here

Extrude your mesh downwards to give it some depth. Add the modifier and experiment with the Octree Depth and Scale values. enter image description here

To see the modifier's effect in Object Mode go to Object header and check the Wire checkbox in the Display panel.
enter image description here


EDIT: Steps to follow in your case:

  • select thw whole mesh (A) in Edit Mode and press W-->Remove Doubles
  • with the whole mesh selected press Shift+S-->Cursor to Selected. Enter Object Mode and press Shift+Ctrl+Alt+C-->Origin to 3D Cursor. Then press Shift+C and finally Shift+S-->Selection to Cursor

enter image description here

  • go to Object header and check the Wire checkbox in the Display panel
  • extrude your whole mesh downwards (E,Z)
  • go to Object Mode and add the Remesh Modifier. Increase the Octree Depth and play with a Scale value. Uncheck the Remove Disconnected Pieces checkbox
  • apply the modifier

enter image description here

  • delete extruded vertices
  • select the top ones and scale them (S,Z,0) to make them flat (if needed)

enter image description here

Here's the result: enter image description here

And a .blend file:

$\endgroup$
  • $\begingroup$ a file attached problem im getting as soon as the remesh added it disappears $\endgroup$ – atek Oct 22 '16 at 6:05
  • $\begingroup$ Updated my answer. Please check it out. $\endgroup$ – Paul Gonet Oct 22 '16 at 15:01
  • $\begingroup$ thanks for replying me and getting that image. as i have notice that 4 image are not similar as i have attach the image/ It looks good from a view but when zoom its not similar. $\endgroup$ – atek Oct 22 '16 at 16:28
  • $\begingroup$ Sometimes some modifiers don't work perfectly, so you have to tweak some things by hand. As you have the clean divisions in your mesh, you may try to delete three patterns and give the remaining one an Array Modifier with the Count number of 4. $\endgroup$ – Paul Gonet Oct 23 '16 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.