1
$\begingroup$

So I basically want this ball to run down the ramp, into the tube and out. But for some reason, the screw tube creates this invisible wall that prevents the ball from going in. The screw tube has Rigid body (passive), and it's shape is Mesh - Deform. ball resists going inside

$\endgroup$
2
  • $\begingroup$ What is the shape of the ball set to? If it's set to something other than sphere, then try sphere. If that is what it's already set to, then try convex hull or mesh. This may or may not make a difference, but it's probably worth trying. And if it doesn't, you may want to share your .blend, by uploading it to Blend-Exchange and editing your question to include the link given to you once the upload is complete. $\endgroup$
    – user27640
    Oct 21 '16 at 7:21
  • $\begingroup$ Thanks, the ball was set to Sphere, tried convex/mesh, still didn't do much, but I uploaded the file to be downloaded. $\endgroup$
    – Tony V
    Oct 21 '16 at 8:23
4
$\begingroup$

The reason your simulation isn't working as expected is because the tube has a screw modifier on it that hasn't been applied.

Apply the modifier to make the geometry real, and it will work just fine. You also should apply tranforms with Ctrl+A rotation and scale (in object mode) on all objects involved in the simulation. Otherwise the simulation can become unstable and have unexpected results.

$\endgroup$
1
  • $\begingroup$ Thank you so much! It works! Thought the screw modifier was applied already. All works well now :) So when I keep adding new obstacles, do I just select the all again, and apply transforms (rot/scal) again, or just select the individual and apply? $\endgroup$
    – Tony V
    Oct 21 '16 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.