0
$\begingroup$

When I take an object and click "quick smoke" and set the flow type to fire, it looks very good in the viewport. However the render looks terrible. Here is an example:

Viewport- enter image description here

Render- enter image description here

It, for some reason, has a black outline. I saw this problem much more when I too the monkey, set to to quick explode, then added a smoke domain. The viewport looked so much more better then what the final result looked like.

Also, is there a way to make the fire not fill up the domain and look like a square in the final result?

$\endgroup$
2
$\begingroup$

The viewer is broken regarding images with alpha, and composites them incorrectly. Never trust it. Never rely on it.

Composite your work using the Alpha Over node against an image and you will have an accurate rendering of your fire.

$\endgroup$
-1
$\begingroup$

To fix this, I would imagine that you have to edit your material. Another reason could be that you are using the Blender Internal (Blender Render) rendering engine, which is far less realistic that the Cycles Render Engine. The option to change this is on the to where it says Blender Render, click on it and select Cycles Render from the drop down list. In case you do not know how to setup a cycles fire material go to this website: Blender Manual Volume Shader

$\endgroup$
  • $\begingroup$ Thank you, but I don't use Cycles. Can you explain the set up of the material and how it would fix my problem? Thanks so much! $\endgroup$ – KingKong19100 Oct 21 '16 at 2:45
-1
$\begingroup$

Well guys so I found my own answer. I clicked the domain, went to the texture settings, clicked the flame, then adjusted the colors on the ramp.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.