0
$\begingroup$

I am using Blender to try to create a simple handgun, though I have run into quite the problem. I am an noob at Blender so please forgive my simple understandings. With edge split it creates blotches and leaves holes as seen here: enter image description here Without edge split it does a similar thing, as seen here:

enter image description here Though it doesn't create holes, it just folds out in a very strange way. Any help is much appreciated.

$\endgroup$
  • $\begingroup$ Subsurface modifier is more complicated on these sorts of objects. You probably want to simple subdivide the mesh first in edit mode to have a less dramatic effect. $\endgroup$ – Bradman175 Oct 20 '16 at 21:42
  • $\begingroup$ The fact that modifier is more complicated for some particular case doesn't mean it can't or shouldn't be used. It is correct to use low-polysinh mesh which will be subdivided further on, it's critical to make its geometry good enough. Regarding the problem it seems that there are double vertices in the mesh. If you upload the mesh and post link here as comment it would be easier to check. $\endgroup$ – Mr Zak Oct 20 '16 at 22:04
0
$\begingroup$

Subdivision Surface modifier folds stuff. It's kind of meant for that. It smooths your mesh, it's not like it actually subdivides. It emulates subdivision placing "imaginary" vertex in middle of the existent ones. Those imaginary ones can't be edited, they move calculated by the program as you move from point to point the real ones, and when you apply the modifier, just then they come to life. There is no way to correct that bending using just the modifier, I believe.

Why don't you try, actually modifying the mesh using Space->Subdivide or in the viewport in Edit Mode: T(on left of view port) ->Subdivide ?

Be aware that will add real vertex to the thing and make it heavy if abused. Next time if you are planning on doing all with the Subsurf, start right from the start using it, and model your thing with it active. I'm telling you that doing that will turn your crazy, because the program will still smooth the planes; I mean you will be working with the vertex putting them in places that make your modified by modifier mesh "nice" to the eye, but at the moment of turning the modifier off at any given moment, you'll realize that the vertex are not actually where you put them. Because the modifier calculates stuff placing them that way so that the algorithm for the modifier shows you nice stuff.

For the time being, use the Subsurf modifier for organic stuff of smooth stuff, and not for sharp edged things like rocks, guns, etc. You can always use cylinders, cubes and subdivide them with "real subdivide". And turn on the Smooth shading in the T menu (on left of view port) in Object mode.

EDIT: Please, take a look at this page. These are the geometries you need. Although 2nd option may be better since doesn't require you to add geometry at all.

Keep sharp edges when using subdivision surface

$\endgroup$
  • 1
    $\begingroup$ Subsurf can be and is used for hard surface modeling, see related . The problem is to create good supporting geometry which won't transform into a bubble. $\endgroup$ – Mr Zak Oct 20 '16 at 22:02
  • $\begingroup$ I agree. I just meant to do that for the time being because he said he was a noob at the moment. But, yes, knowing where to put supporting geometry does the trick. $\endgroup$ – Facuz Oct 20 '16 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.