4
$\begingroup$

In Blender 2.69 I can't figure out why hair particles are unaffected by mist. I'm using tangent shading if that makes a difference.

Does anyone know how to fix this? (see image) Thanks!

Problem with hair particles

UPDATE: Ok, I think I figured it out somewhat. And yes, I am using blender render, not cycles, sorry about that.

If I turn off 'Strand render' in the particle settings it works!

Strand render off

But the hairs, or needles in this case, don't render quite as well as with strand render on...

Strand render on

If someone knows a way around this, that would be great to know. But I'm content with the way it looks either way. Thanks again!

$\endgroup$
  • $\begingroup$ Are you using BI or Cycles? And is it possible you could upload a .blend? $\endgroup$ – gandalf3 Jan 27 '14 at 3:14
  • $\begingroup$ Strand works fine for me.. Is it possible you post a screenshot of your material and particle settings or better, a blendfile? $\endgroup$ – gandalf3 Jan 30 '14 at 18:16
  • $\begingroup$ @gandalf3, to be honest, when I tried it just now with strand it worked. But I'm still getting the same problem with my trees as before. Here's a .blend... link $\endgroup$ – Sminch04 Feb 1 '14 at 0:50
  • $\begingroup$ That is strange.. I got better results when using the mist pass and disabling mist in the materials. Example file $\endgroup$ – gandalf3 Feb 1 '14 at 1:18
  • $\begingroup$ That's a great alternative, thanks for the help! $\endgroup$ – Sminch04 Feb 1 '14 at 2:12
2
$\begingroup$

Make sure you had the "Use mist" option on the particles material. You could post some file showing the problem. The image had some post process?

$\endgroup$
0
$\begingroup$

It might be of use to others seeking an answer, but in my case it's because my material for the leaves has Z Transparency instead of Raytrace. Changing it to Raytrace immediately applies mist to them. (Both cases has "Use Mist" checked, and I didn't use a particle)

enter image description here

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.