7
$\begingroup$

I've created a Bezier curve, and used to shrinkwrap modifier to project it onto my object:

object and curve

Now I want to cut along the curve, splitting the mesh into two.

How can I do this? If I just use knife project, I would lose the 'lid' part.

$\endgroup$
9
$\begingroup$

Method 1

  1. There is a Cut Through option for Knife Project tool, as shown in Figure 1 below (btw, since Knife Project tool doesn't require the curve being snapped to the surface, the Shrinkwrap modifier isn't quite useful here, just make the projected cut through the ortho view, Top view in your case);

  2. P to separate the default selection after that, see Figure 2;

  3. Select one object, enter Edit mode, A to select none, ShiftCtrlAltM to select the cutting edge loops (in Vertex or Edge select mode), then W > Bridge Edge Loops. Repeat it on another object. See Figure 3.

enter image description here enter image description here enter image description here


Method 2

There is another nice script called Sculpt Tools shared in Blenderartists.org, which can do this in one stop. But the final mesh needs a bit refinement compared to Method 1 here.

enter image description here

(Image by the addon author Piotr Adamowicz)

There is also a similar addon called Sculpt Trim Curves Utility, which also did it. But I'm not sure if it still works well with the latest blender version.

enter image description here

(Image from blendernation.com)

$\endgroup$
  • $\begingroup$ Thanks Leon, I'm stuck because I don't get a "Cut Through" checkbox. Also your shelf has vertical tabs, are you using a development build? The moment I apply Knife Project, the small part disappears, leaving a hole in the top of the cube, which your picture doesn't show. $\endgroup$ – P i Jan 26 '14 at 20:32
  • $\begingroup$ Yes, I'm using the daily build, which got vertical tabs. :). However, you said you left a hole after knife project, that's really strange. You can try the latest release, if it still happen, it's unlikely to find what's going on there unless seeing the .blend file. $\endgroup$ – Leon Cheung Jan 27 '14 at 5:14
  • $\begingroup$ My mistake was that I was in solid view not wireframe view. In wireframe view it works. Maybe a little bug? $\endgroup$ – P i Jan 27 '14 at 12:54
  • $\begingroup$ That's possible. But again, try using the latest build, if the problem is gone, then it maybe fixed already. Otherwise, you may try to report it here. $\endgroup$ – Leon Cheung Jan 27 '14 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.