1
$\begingroup$

After changing the hotkey "Selection" tool began to work by clicking the Left Mouse Button+Ctrl/Alt (Select/deselect). I'm just fine with that, but there is one catch:

If use the Border Selection outside the object (LMB+Ctrl or Alt) this tool is working correctly, but if using it within a object, before created selection is cleared.

For example: If I need to add additional polygons to the current selection

1) enter image description here

2) enter image description here

What I need to change or add to this tool works correctly within the current object and active selection is not reset?

Current HotKey: enter image description here

$\endgroup$
3
  • $\begingroup$ There is probably nothing wrong with your border select key definitions, its probably the Select/Activate operator that is resetting your selection. Try change it to either to a Mouse Release event or to Extend Selection by default. This is very likely a limitation of the current system I've bumped into in the past myself $\endgroup$ Commented Oct 17, 2016 at 23:56
  • $\begingroup$ @DuarteFarrajotaRamos Would you like to post that as an answer? R_M_S, when he does, make sure you accept it. $\endgroup$
    – JakeD
    Commented Oct 18, 2016 at 0:24
  • $\begingroup$ Certainly, posted bellow. $\endgroup$ Commented Oct 18, 2016 at 0:38

1 Answer 1

1
$\begingroup$

There is probably nothing wrong with your Border Select key definitions, its probably the Select/Activate operator that is resetting your selection.

Try change it to either to a Mouse Release event or to Extend Selection by default, so there's no conflict and starting a border select won't unintentionally trigger the colliding operator.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .