0
$\begingroup$

The node setup is quite simple:
image
and the experimental image is : enter image description here (only the red is opaque other part is transparent).
So why can't we texture images with alpha values? Is this a bug? I've tried JPEGs and it works fine but we can't texture objects with any image textures that have alpha.
Note, this is the problem with the 32-bit version of blender 2.78, I don't know about the 64-bit version since it didn't work on my PC.

Please see the comments below before downloading the blend. The problem would not be evident unless the file is unpacked.

$\endgroup$
  • 1
    $\begingroup$ The magenta color on the sphere suggests that there is a problem with the loading of your texture. Can you see the image correctly in blender's image viewer? $\endgroup$ – Gez Oct 17 '16 at 3:10
  • $\begingroup$ @Gez, let me upload the blend $\endgroup$ – BumbleBee Oct 17 '16 at 3:59
  • $\begingroup$ @Gez, I was on my way to packing the files when the texture worked.Is it having problem following the directory then? It only works when the file is packed within blender? Should I upload the file anyway? $\endgroup$ – BumbleBee Oct 17 '16 at 4:06
  • $\begingroup$ Pink textures mean that the program cannot load the image file. This could be because the image is in a different folder on the system than the one determined in the blender scene. In any case the problem has nothing to do with the 32bit or 64bit versions of blender. On a different note: jpeg files cannot have alpha channel. $\endgroup$ – cegaton Oct 17 '16 at 9:32
  • $\begingroup$ related: blender.stackexchange.com/questions/41060/… $\endgroup$ – cegaton Oct 17 '16 at 9:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.