2
$\begingroup$

Basiclly I was following this tutorial: https://www.youtube.com/watch?v=pBRMh5QZ1n8

and I've done everything correctly but when I render it, only the text renders without the extra halo scenes. here are some screen-shots if it helps:enter image description here (I think)

If you need more screenshots or info just say specifically as i'm kinda new to blender only started properly learning it like 5 days ago.

EDIT: Ye that helped with the transparency but no luck the text is on it's own still when rendered enter image description here

If anyone would be kind enough to go through the file and see what's wrong here is the link ;)

or request more screenshots if you need more info.

$\endgroup$
  • $\begingroup$ Upload your file to Blend-Exchange instead. Edit your question and include the link given to you once the upload is complete. $\endgroup$ – Duane Dibbley Oct 13 '16 at 21:48
  • $\begingroup$ I believe I found you problem. Did you set the Alpha to Transparent on all scenes? If so, change it back to Sky on Scene.001 and Scene.002. $\endgroup$ – Duane Dibbley Oct 13 '16 at 22:01
  • $\begingroup$ You have to selected "Composite" instead of "Renderlayer" in the image editor. $\endgroup$ – Leander Oct 13 '16 at 22:07
1
$\begingroup$

The scene with the text doesn't look liike it has any transparency, so when you Alpha Over it on another image, it completely covers that image. Change Alpha to Transparent under Shading in the Render tab. Change this only on the scene named Scene in your file. Scene.001 and Scene.002, which contain the halos, should keep the default setting, Sky. The halos really do get rendered, but they are so faint, that they're just not visible enough without a background.

enter image description here

You can also set them all to transparent and insert a second Alpha Over node like this, to be able to contro, the background colour.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ Thanks a lot, the transparency was the problem and how faint the halo's were. Thanks for everyone's contribution :D couldn't find an answer to this anywhere. $\endgroup$ – Encryptor Oct 14 '16 at 5:45
  • $\begingroup$ @Encryptor You're welcome. I had a similar problem once, and it took me some time to solve it. $\endgroup$ – Duane Dibbley Oct 14 '16 at 5:59
  • $\begingroup$ sorry but with my luck obviously this is just the beginning the text is treating the scenes as background and I want them to render together, so that the halo's in front of the text like smoke and red glowing dots appear in front of it as well, first I thought; oh the halos are further than the camera so no particle is actually in front of the text but then i made it really dense and it still treats it as a background. :P any help with my never ending problem? $\endgroup$ – Encryptor Oct 14 '16 at 17:34
  • $\begingroup$ - ignore me I'm just being an idiot XD $\endgroup$ – Encryptor Oct 14 '16 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.