1
$\begingroup$

I'm using matcaps as materials most of time, using blender internal render and cycles with nodes or without, by making the material shadeless and setting the mapping coordinates to normal. I want ambient occlusion to affect the final render.

render without ambient occlusion

$\endgroup$
2
$\begingroup$
  1. Enable the Ambient Occlusion in the World section of the properties panel. Set it to Add.
    enter image description here
  2. Create a new material: "Ambient".
  3. Set the Diffuse Intensity to 1, and the Color to (1, 1, 1). Rendered view will show the ambient occlusion of the material.
    enter image description here
  4. Create a new material: "mixedMaterial". Assign it to the mesh.
  5. Enable nodes, add the "Ambient" Material, the "Matcap" Material and combine them with a Color Mix node. Set the Mix nodes mode to Multiply.
    enter image description here

This is the result.

enter image description here

$\endgroup$
  • $\begingroup$ After apply your advice -- it works thanks :) but I need to control Ambient Occlusion on [Node] like here on 3D viewport $\endgroup$ – Husham Oct 14 '16 at 7:50
  • $\begingroup$ here ---->>> link $\endgroup$ – Husham Oct 15 '16 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.