0
$\begingroup$

Hi I've got left mouse navigation working in object mode but in edit mode it doesn't work.

Alt Left - Rotate Shift Alt Left - Pan Ctrl Alt Left - Zoom

Also this only breaks when using left mouse selection

Any ideas why it would work in Object mode but not in edit mode?

Thanks, Vaughan

$\endgroup$
1
$\begingroup$

Yes, this happens when you use "LEFT" click selection (not the default).

the shortcuts you used above need the "emulate 3 button mouse" setting enabled... which you can do with "RIGHT" click selection:

enter image description here

but as soon as yu enable "LEFT" click selection, the setting is unavailable (greyed), and thus those shortcuts doesn't work anymore

enter image description here

I guess you're on Windows, and I suggest you to use a little utility (called X-mouse, or a similar one) I suggested in another answer, here;

Can't navigate in the 3d view

With that, you can have an automatic setup just for Blender mouse usage, and your 3 button mouse will use the middle button as it is intended by Blender, so you don't need the "emulate 3 button mouse" setting, and thus you don't need the shortcuts either...

hth

$\endgroup$
0
$\begingroup$

Just figured it out, instead of using the select with left input preset you have to manually specify selection otherwise defaults override the alt left for navigation.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.