1
$\begingroup$

Why does the AO render pass result in a black environment?

Shouldn't this be white as default?

Also, Is it possible to get a transparent environment within the AO render pass? White should do just fine as well.

PS: I know there's a workaround by making use of the Object/Material index to mask out parts of a layer. but this is really tedious if you've got a large complex scene.

Ambient occlusion

$\endgroup$
  • 2
    $\begingroup$ Hate this too, makes no sense. You could put a White plane far away from the scene and only enable it to be seen by diffuse rays, should be visible in AO pass I reckon. It is a workaround though. $\endgroup$ – Alphisto Oct 11 '16 at 14:37
  • $\begingroup$ This could work for a simple seen which only requires AO. Problem with this technique: It would cancel out the environment texture. Which in it's turn could be made visible though by using 'is camera ray' etc. in the node editor. But yet again...tedious workaround :) $\endgroup$ – Delagone Oct 11 '16 at 15:02
1
$\begingroup$

AO render pass result in a black environment cause it doesn't contain Alpha channel.To get any AO You have to have some objects in field of view, otherwise there is nothing to cause Ambient Occlusion.

There is a very simple way to achieve AO pass with transparent background. In the node setup You have on the attached image (assuming, that You have transparent background enabled) You just need to attach Alpha output from Render Layer Node to Alpha input in Composite or Viewer node.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.