1
$\begingroup$

I know this is experimental technology and I shouldn't get my hopes up; I installed both the proprietary Intel OpenCL SDK (2016) and open-source Beignet (they don't seem to be interfering with one another) and devices appear under the OpenCL category when I run Blender 2.78 with

CYCLES_OPENCL_SPLIT_KERNEL_TEST=1 blender

The Beignet drivers are giving me compilation errors, but the Intel render kernels work for CPU rendering only. When I attempt GPU rendering ("Intel HD Graphics" option), the render will stop on the first tile and will not progress further. I get no errors; with the Supported feature set I only get the message "Device init success" and with the Experimental feature set, I get the list of successfully compiled kernels. I have tried running as root with the same results. After several minutes, I get the errors:

OpenCL error (Intel(R) HD Graphics): Hardware running slow or hung.
OpenCL error (Intel(R) HD Graphics): Out of resources.
OpenCL error (Intel(R) HD Graphics): Out of resources.

I have an Intel® HD Graphics 530 (Skylake GT2) graphics chip alongside a quad-core Intel® Core™ i5-6300HQ CPU.

Perhaps it's time to get a dedicated GPU, but I'm wondering -- has anyone had success with this setup?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.