3
$\begingroup$

I've searched Google and has no luck finding a solution hopefully someone can give me some info and what I should do about it.

I have:

  • GT 640m 2Gb <- a Laptop
  • Driver ver: 368.81
  • DirectX runtime version: 12.0
  • Direct3D API ver: 12
  • Cuda Cores: 384
  • Graphics Clock: 624 Mhz
  • Memory Data rate: 1800 Mhz
  • Dedicated video memory: 2048 MB DDR3
  • Bus: PCI Express x16 Gen3
  • Compute Capability: 3.0 ---> https://developer.nvidia.com/cuda-gpus
  • NVCUDA.DLL fileversion: 6.14.13.6881
  • NVCUDA.DLL Product Name: NVIDIA CUDA 8.0.0 driver
  • Intel Core i5 3210M CPU @ 2.50Ghz
  • Windows 10 64bit OS
  • 8Gb Ram
  • Intel HD Graphics 4000
  • 1366 x 768 32bit 60Hz Display

enter image description here

Blender 2.78 4bb1e22

I have no problem rendering using the CPU, but it is extremely slow. So slow that I've decreased sampling to just the base number of 8.

I'm thinking that I could do more once I render using GPU rendering, but whenever I used it, it never actually renders, in fact it stops right after BVH percentage is complete and just shows a blank render. Pressing Esc exits render back to 3D viewport and shows the error:

Cuda error at cuCtxCreate: Illegal Address

EDIT:: Updating Nvidia graphics driver to 373.06 didn't worked as of 19/10/16

EDIT:: as of 30/01/17 My current settings is

  • same old Lenovo z480 laptop
  • OS: Linux Fedora 25 64bit
  • Kernel: 4.9.5-200
  • Graphics driver: bumblebee-nvidia, nvidia 375.25 and cuda 8.0.44 toolkit

Even with new OS and a different graphics driver I am still getting that cuCtxCreate.

EDIT:: as of 30/01/17

  • Lowering the Memory Transfer Rate has fixed this issue for me, thanks to andrej solution.
$\endgroup$
  • $\begingroup$ Don't know if this info helps, but I get the same error with a gtc1070, but only if I'm running it with an overclock $\endgroup$ – andrej Jan 21 '17 at 21:58
  • $\begingroup$ Thanks @andrej, I haven't overclocked my GPU before, but you gave me an idea. I lowered the Graphic Clock Offset and the Memory Transfer Rate offset and the GPU Rendering worked, experimented a bit and even with just the Memory Transfer Rate lowered I can still use GPU rendering, though it feels like I am playing a game in a frying pan. Thanks again :D $\endgroup$ – Donato Esparas Queyquep Jan 30 '17 at 2:38
2
$\begingroup$

Updating the driver should fix it but you might have stability issue white blender instead. We will probably just have to wait on another update for blender to fix the stability problem.

$\endgroup$
  • $\begingroup$ It isn't a solution but it might be better than it not working at all. $\endgroup$ – Alfons Marklén Oct 9 '16 at 9:47
  • $\begingroup$ I've update the driver months ago right after the release of 2.77 and it didn't worked. but, you just reminded me that this 2.78 release has some fixes with Cycles GPU, I read it somewhere, I'll try and update my drivers again, Thanks. $\endgroup$ – Donato Esparas Queyquep Oct 10 '16 at 3:37
  • $\begingroup$ Update the driver fixed the problem $\endgroup$ – Alex Nov 20 '18 at 5:07
  • $\begingroup$ same problem for me with the latest nvidia creator drivers. $\endgroup$ – user3597862 May 8 at 12:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.