2
$\begingroup$

If you have an image in the UV/Image editor window, pressing the Home button is for View All.

Why does it put a massive border around the image? Every time I press Home I have to zoom back in!
Zoom extents would be a lot more useful.

Is there a reason for this zoomed out border?

$\endgroup$
3
$\begingroup$

As far as I remember, it snaps to the same zoom ratios as you use the numpad for (1:1, 1:2, 1:4, 1:8...). This is probably to avoid any scaling artifacts since the Image Editor does not filter the images.

If you want to view the image fit to the borders better, try pressing F. However this will not set it to 1:1 if the image is smaller than the region.

Personally, I think there could be some more consistency in this regard, keeping the same hotkeys throughout editors would be nice.

$\endgroup$
  • $\begingroup$ Thanks. F works perfectly. Yes - this is a bit inconsistent with the rest of the interface. $\endgroup$ – Ollie83 Jan 22 '14 at 13:59
2
$\begingroup$

Aside from centering the image, pressing Home sets the zoom level to 1:1 or fits the image to the view if it's larger than the UV/Image Editor window.

You can press Numpad 1 to quickly get back to 1:1, or CtrlNumpad 2 for 2:1, etc. You can see a list of the available aspect ratios and their respective hotkeys in the View menu on the Header of the UV/Image Editor window.

$\endgroup$
  • $\begingroup$ This does not explain the border. The Home button is neither 1:1 or fit to view. $\endgroup$ – Ollie83 Jan 22 '14 at 10:20
  • $\begingroup$ @Ollie83 It is for me.. Perhaps it's a bug. Could you a screenshot? Note that there may be some gap as fit to view seems to pick the closest aspect ratio it can find out of the options in UV/Image Editor > Header > View. $\endgroup$ – gandalf3 Jan 22 '14 at 10:21
  • $\begingroup$ I think you are correct. The home button picks the nearest standard zoom level - rather than actually fitting to the view! This is a bit of limitation. As when you render at 1920x1080 - if you monitor is the same res - home will only zoom to 1:2 $\endgroup$ – Ollie83 Jan 22 '14 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.