1
$\begingroup$

I've selected a material view and here's what happened with the cube. I'm sure it's not a camera max clip distance problem, because outline and grid is visible. It is appears only when GLSL mode is active.

weird cube

$\endgroup$
  • $\begingroup$ Can you add a screenshot of it in Edit Mode if that's not what we're looking at already? It looks like there are "false faces" which I've experienced only when unwanted vertices get included in a fill operation. Often caused in my case, by minute buckling. $\endgroup$ – Edgel3D Oct 8 '16 at 14:49
  • $\begingroup$ You may also have double edges - edges overlaying edges. "Removing doubles" doesn't fix these. I am often forced to delete edges and keep deleting until that edge finally disappears, then press CTL-Z to restore the last one, leaving me with just a single edge. $\endgroup$ – Edgel3D Oct 8 '16 at 14:59
  • $\begingroup$ @Edgel3D it's a startup scene, nothing special. $\endgroup$ – Ocelot Oct 8 '16 at 15:03
  • $\begingroup$ change rendering settings in viewport at something higher and it might work :/ $\endgroup$ – xlxs Oct 8 '16 at 15:20
  • $\begingroup$ It's gotta be a setting surely? If @xlxs suggestion doesn't help, save it and add it here so we can look at it. $\endgroup$ – Edgel3D Oct 8 '16 at 15:48
2
$\begingroup$

The only way I can get anything like what you're seeing is to reduce the viewport's "clipping" END setting (press N and open the VIEW tab) to something below the START setting then approach the cube until this happens...

enter image description here

Another point might be to ask where you downloaded Blender from? I make a point of using the original/authoring site, never a third party site for any s/ware.

This is obvious I know but failing all else, you might also want to explore the possibility of it being a problem between Blender, the graphics card or it's drivers, or perhaps your operating system and/or it's version.

I see your latest comment and note that you're using Win XP? That's pretty old isn't it? Blender has come a long way since the older versions of Windows. Perhaps XP can't handle what Blender is doing re - shading etc.

When all else fails, look for the things it cannot possibly be!

EDIT: I've since found out that XP is not supported by Blender versions beyond 2.76B

$\endgroup$
  • $\begingroup$ It's a bug then, isn't it? Because clip distance does nothing and never did, in my situation (I've already stated that In my question, actually). Strangely enough, this bug disappeared recently, so I'm unable to report it anyway, even if XP isn't supported, because I have no idea how to reproduce it... $\endgroup$ – Ocelot Oct 11 '16 at 13:06
  • $\begingroup$ Yes I did see your reference to the clip distance but the starting distance can easily be discounted, hence why I mentioned it. As the bug has disappeared your PC might have done a background driver or OS update? Either way, all is well again! $\endgroup$ – Edgel3D Oct 11 '16 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.