1
$\begingroup$

Sometimes I get these weird white reflections, that don't look real at all. I have a white sunlamp in the scene. Is there something I can do to stop this?

enter image description here

EDIT:

10x smaller sunlamp, added glare (perfect ad for a washing up liquid).

enter image description here

$\endgroup$
  • $\begingroup$ Try changing the emit color of the lamp and see if the reflection changes as well. This would help narrow down the problem at lease. $\endgroup$ – Josh Silveous Oct 7 '16 at 17:37
  • $\begingroup$ @JoshSilveous yes, when I change it to green they are green. $\endgroup$ – Noidea Oct 7 '16 at 17:39
  • 1
    $\begingroup$ Try Selecting the light object, then navigating to the object panel. Under that, find "Ray visibility". Under that, deselect the "Camera" box. In theory, this should cause the light to render but not the light source itself. I would provide images but I am not currently at my workstation. $\endgroup$ – Josh Silveous Oct 7 '16 at 17:50
  • $\begingroup$ @JoshSilveous "Camera" ray visibility had no effect. It disappears when I switched off "Glossy" ray, but of course so do all other glossy reflection of this light, e.g. the one in the middle at the bottom of the picture. $\endgroup$ – Noidea Oct 7 '16 at 18:00
  • 1
    $\begingroup$ @Noidea Here is a link to some free "Garage" like HDRi's that might work really well mrbluesummers.com/category/downloads/… and one of many tutorials out there youtube.com/watch?v=_4IN4V1SM-A $\endgroup$ – Dontwalk Oct 7 '16 at 19:51
4
$\begingroup$

That is the reflection of the sun lamp. The size is related to the size property of the lamp. If you change it to 0, it will disappear. You will also have perfectly crisp shadows.

The sun lamp reflection looks unnatural because cycles produces a perfect reflection, instead of the soft edged sun were used to seeing because of the atmosphere. And there is no bloom that happens in your eyes or in cameras to bright objects. More info

So instead, You can add the bloom as a post process.

Or, use HDR an illumination map instead of a sun lamp.

Or, on the lamp, uncheck the box for "Multiple Importance". If the glossy shaders have no roughness, or set to "Sharp", the glint with disappear...

More info on multiple importance: 1 2

$\endgroup$
  • $\begingroup$ Thanks, so as far as I see every solution to these problem has its downsides, e.g. unchecking multiple importance leads to noisy render. I'll try the composer. $\endgroup$ – Noidea Oct 7 '16 at 19:17
  • 1
    $\begingroup$ Also, your sun reflection seems very large, You may also consider also reducing the size... perhaps from the default .1 to .01. if not lower... as well as adding a bloom. But again, the point is that cycle's sun does not work like the sun we're used to. I'd look into HDRI. $\endgroup$ – JTxt Oct 7 '16 at 19:34
  • $\begingroup$ yes, I had 0.1 sun, reduced it and the highlight is much smaller now. HDR is good, but I find it hard to get the sun in the right direction. And I need to show some different background, because rotated HDR looks weird. $\endgroup$ – Noidea Oct 7 '16 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.