6
$\begingroup$

I am trying to use the emission shader to make a light, but I realized that it seems to be only shining through to a limited extent:

lighthouse with failed shader

These are the nodes for the light:

light nodes

These are the nodes for the glass:

glass nodes

How can I make it so that it illuminates objects on the other side of the glass?

$\endgroup$
  • $\begingroup$ Do you have No Caustics enabled in Render settings > Light Paths? $\endgroup$ – gandalf3 Jan 22 '14 at 2:40
  • $\begingroup$ oh that's what it was. thanks for pointing that out! $\endgroup$ – ZCoder Jan 22 '14 at 2:45
6
$\begingroup$

Make sure you have caustics enabled by unchecking No Caustics in Render settings > Light Paths:

enter image description here

With caustics:

enter image description here

Without caustics:

enter image description here

$\endgroup$
  • $\begingroup$ All it shows for me is Reflective Caustics twice, Whats up with that (Cycles Render)? $\endgroup$ – Sean Feb 12 '17 at 2:51
  • $\begingroup$ Reflective And Refractive Sorry $\endgroup$ – Sean Feb 12 '17 at 2:51
  • $\begingroup$ @Sean The "no caustics" setting was split into separate settings for reflection and refraction a while back. In this case at least the refractive part should be enabled to allow rays through the glass material. $\endgroup$ – gandalf3 Feb 12 '17 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.