I'm not sure if there is a question already about this but when I try to render with the GPU and change the Compute Device setting to my GPU, I am missing the Feature Set and Device options under Render which don't allow me to change the device used.

Can anyone guide me on what I am doing wrong? Thanks.

User Preferences with GPU selected

Render section with none of the options I mentioned earlier


Only the 'Cycles' rendering engine can make use of the GPU. The 'Blender Render' engine (which you are using) only has the option to use CPU.

You can change to the Cycles render engine on the top toolbar, but it is very different to the 'Blender Render' and objects will need different materials made for them:

enter image description here

Once 'Cycles' is chosen the 'Feature Set' and 'Device' settings will appear in the Render panel.

  • $\begingroup$ Thanks for the answer I will try that out now. :) And don't worry, I'm only rendering a video with it so nothing is supposed to be changed. EDIT: I'm not seeing any big change in performance... I changed the setting, closed and opened up the project but not that much of a difference. I have an i7-6700 CPU and a GTX 1070 as you saw. $\endgroup$ – andracer108 Oct 6 '16 at 18:04
  • $\begingroup$ When you say 'I'm only rendering a video', do you mean you're using the VSE? The VSE doesn't use the GPU anyway (as far as I am aware). $\endgroup$ – Ray Mairlot Oct 6 '16 at 18:12
  • $\begingroup$ When I say that, it means I changed the active screen to Video Editing (sorry I'm not sure what you are saying is correct). $\endgroup$ – andracer108 Oct 6 '16 at 18:34
  • $\begingroup$ Yes, the VSE is the 'Video Sequence Editor', which is what appears when you change to the 'Video Editing' layout, so if you're using that you shouldn't expect any speed-up from GPU. $\endgroup$ – Ray Mairlot Oct 6 '16 at 18:36
  • $\begingroup$ Yes, I am using that. Oh ok, no problem. Just to confirm, is there no other way I could speed it up? Or is that it? $\endgroup$ – andracer108 Oct 6 '16 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.