0
$\begingroup$

I've got a scene that I've motion tracked and it seems to be working well. Then I used "Setup tracking scene" to create a cube layer, then a floor layer that would only exist to act as a shadow catcher. When I render this in Blender Render, such as Blender Guru does in his tutorial video, it looks fine. However, because of what I would like to do with this scene in the future, I would rather use cycles instead of blender render. However, I don't think the nodes are set up right or something because when I render it in Cycles, the floor layer still appears. I would like the floor layer to only act as a shadow catcher AND (this is hard to describe) a layer where anything behind it would not be rendered. So like if I had a cube that stuck through the floor layer, only the part that is in front of it would be shown. I should also note that I have no experience with nodes, so that's probably the problem.

$\endgroup$
4
  • 3
    $\begingroup$ As long this feature is in development, you can find a nice workaround here. $\endgroup$
    – p2or
    Oct 4, 2016 at 13:28
  • $\begingroup$ @poor I forgot to mention that I would like the shadow catcher layer to not render in the final result, but it's shadows will. Will this method provide that? $\endgroup$ Oct 4, 2016 at 14:06
  • $\begingroup$ What poor means is there is currently no one-step solution to do what you want. You have to set up a mix of material nodes and compositing solution $\endgroup$ Oct 4, 2016 at 14:27
  • 1
    $\begingroup$ related: blender.stackexchange.com/questions/47569/… $\endgroup$
    – user1853
    Oct 4, 2016 at 17:52

1 Answer 1

1
$\begingroup$

This feature is now included.

Select the shadowcatcher object, go to the object properties and check Shadow Catcher under Cycles Settings.

It will render a shadow but mask the object behind it.

shadowcatcher

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .