0
$\begingroup$

I am trying to use bones in my model to (at the moment) make it wag its tail. However, when I bend the bones, the tail deforms strangely and won't bend properly. I have tried fiddling with weight painting, but nothing i have tried so far will work.

Images for reference here

EDIT: Sorry, forgot to put a picture that showed the deformation. I've added it to the album ^^. I fixed the bending issue, however whenever I bend it, the inside edge of the tail caves inwards. Also, there is this one stubborn vertex that moves significantly less compared to the other ones, although it is painted in the same weight. This might be a similar thing?

$\endgroup$
1
  • $\begingroup$ Make sure no other bones in the body have weight on the tail. $\endgroup$ – Erik Oct 7 '17 at 13:57
1
$\begingroup$

I don't see any strange deformation there. You weightpainted the same vertices with full weight to multiple Bones, so the vertice position is interpolated between all the Bone locations which have weight assigned to them.

You have to weight the vertices only to one Bone, and maybe use some low weight blending between them.

The Updates Issue has most likely the same root: the bad vertice is influenced by another bone - doublecheck that all other bones have 0 weight on it and the correct Bone has full weight.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.