Can someone help me? Every time I try to run blender it keeps I get the same error, I tried to install blender as a zip file, install a previous version that I know worked for me before (on the same computer as now), install blender from Steam, and search all over the internet, here is the error message:

found bundled python: C:\Program Files\Blender Foundation\Blender/2.78/python
Fatal Python error: Py_Initialize unable to load the file system codec
 File "C:\Python27\Lib\encodings\__init__.py", line 123
  raise CodecRegisteryError,\
SyntaxError: invalid syntax

Current thread 0x00002a20 (most recent call first)

Thanks in advance for any help.


That looks like Blender is using a very old version of Python. Try taking any path in C:\Python27 off your PATH environment variable.

I'm assuming you're running Windows 10, since you clearly use Windows but don't mention which version. Right-click on "This PC", then choose "Properties". In the next screen, click "Advanced System Settings", then click on "Environment Variables". In both the box "User variables for {your name}" and "System variables" doubleclick on "Path" (or any other capitalisation) and remove anything that starts with C:\Python27.

You may want to write down the original values you removed, just so you can restore them later.

| improve this answer | |
  • $\begingroup$ Can you help me do that? please? $\endgroup$ – ilay1034 Oct 3 '16 at 20:38
  • $\begingroup$ I've updated the comment. $\endgroup$ – dr. Sybren Oct 3 '16 at 20:44
  • $\begingroup$ THANKS SO MUCH! Apparently I added Python as an environment variable when trying to set up a server using python for another device to connect to. I took it out of there and blender now works perfectly! thanks! Also, sorry for that question, but I already figured out how to do that! (I'm a geek in learning). $\endgroup$ – ilay1034 Oct 3 '16 at 20:47
  • 1
    $\begingroup$ You're welcome :) Don't forget to mark this as the answer to your question. $\endgroup$ – dr. Sybren Oct 3 '16 at 20:48

When I was trying to use blender, I had a python path as an environment variables. Therefore, blender was unable to use it (I think), so I deleted the path and blender started working.

P.S I may be wrong, but the python path in environment variables was what causing me the problem.

| improve this answer | |
  • 4
    $\begingroup$ If someone gives you the correct answer, please mark that answer as "accepted". Don't write your own answer too. $\endgroup$ – dr. Sybren Oct 3 '16 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.