1
$\begingroup$

Having some issues viewing/rendering an Image Sequence over a movie clip, both in Compositor and the VSE, and my troubleshooting research is bringing no luck.

I'm able to play and view the animation of Fac. values in a Mix RGB node that I made in the render preview of the 3D view, but not in the Node View, nor in the VSE View. Similarly, and weirdly enough, when looking at my actual rendered PNGs in the directory of my Output Path, I'm only seeing the Background Clip of the movie I'm trying to lay the animation over, and none of the animated color values that should be there. New to animation; am I missing something crucial here?

My setup in the Compositor and VSE, and thanks much ahead:

enter image description here

enter image description here

$\endgroup$
1
$\begingroup$

What I get from your nodes and description is, that you want to overlay your rendered image sequence from the 3D view onto a movie clip. Unfortunately, the red marked clip is not the render from the 3D view, but in fact as you noticed correctly, an image sequence of your movie file.

Why did this happen?

When pressing the Animation button to render you sequence, Blender check first if there are clips in the VSE. If there are, Blender will render these clips only. If there is nothing to render in the VSE, the compositor nodes are checked. If you are using nodes, Blender will render the nodes only. If there is nothing in the compositor and the VSE, Blender will only render the 3D view.

I'm guessing you had the movie clip in your compositor, when you tried to render the 3D Viewport animation. Thats is why, the composite node got rendered into an image sequence (which is connected the the movie file).


  1. In order to render your 3D Viewport image sequence first, disable the Sequencer and Compositing rendering in the Properties Panel.

Post Processing Settings

  1. Render the image sequence. Your png files should look correct now.

  2. Enable Compositing again. You will have the correct preview in the Compositor. When you render, the composite node will get rendered into the output. That's why you have to change your image sequence now, because you don't want to overwrite the 3D Viewport image sequence.

Viewing the 3D preview in the compositor or VSE

Even though pre rendering the 3D image sequence is useful for realtime feedback, you can simply add the 3D render into the compositor by adding a Renderlayer node. Use it instead of the prerender sequence.

renderlayer node

The same can be done in the VSE by adding a Scene strip.

scene strip in VSE

$\endgroup$
  • $\begingroup$ thank you for the clear, in depth answer. This was really helpful, and worked liked a charm. Cheers $\endgroup$ – j_a_l Oct 3 '16 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.