3
$\begingroup$

I'm editing a video that needs a stereo effect (a sound moving from right to left) and I have the audio file without the effect. I just want to have two separate audio strips from that file for each stereo (left/right) and fade the audio in each strip to accomplish the effect, but I can't find the way to indicate which strip corresponds to which stereo.

Is it possible to do that in Blender's Video Editing?.

$\endgroup$
  • $\begingroup$ You could change the name of the two strips (to something like "Left Audio" and "Right Audio"), or even change the color of the sequencer strip. Or am I thinking about this wrong? $\endgroup$ – Gliderman Oct 2 '16 at 13:24
  • $\begingroup$ @Gliderman changing names doesn't affect the strip's audio properties, I mean you won't activate right or left channel by just changing the name. What I need is to separate the channels or making one strip that pans from left to right. Leander's answer seems to be the right way to go, but it didn't work for me. I'm still trying to make it work and if it finally does I will mark the answer as solved. $\endgroup$ – YoMismo Oct 2 '16 at 14:11
3
$\begingroup$

In the Video Sequence Editor, add both audio clips.

On the left audio strip, set the Pan property to -1 under the Strip settings > Sound. On the right audio strip, set the pan property to 1.

Keyframe the Volume property (hover over it and press I to set a key) from 0 to 1 to make the audio fade from mute to 100% audible.

keyframe sound properties

While this may work for some cases, I'd advise you to use a audio editing software (like the freeware audacity).

$\endgroup$
  • $\begingroup$ Thanks for the answer. It doesn't seem to work but it may be me, maybe there is a setting somewhere where you enable stereo sound. I thought about two strips because I didn't know about the pan, but if it finally works then I will try keying pan from 1 to -1 and save one strip ;). I'll come back and mark this as solved if I finally manage to do the stereo effect with the pan parameter. $\endgroup$ – YoMismo Oct 2 '16 at 14:03
  • $\begingroup$ Try checking the mono box, then animating the pan. Maybe thats what you want? $\endgroup$ – Leander Oct 2 '16 at 14:19
  • $\begingroup$ Exactly, that was the problem. I had to check the mono box (kind of weir to me) and everything works with just one strip. I paned from the max to the min values of pan (2 to -2). Thank you very much. $\endgroup$ – YoMismo Oct 2 '16 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.