10
$\begingroup$

This question already has an answer here:

I added two planes in Cycles with Image Texture in png with some transparency. I covered one by the other but transparency doesn't work, I mean it is impossible to see the one which is under despite transparency in the one which is above. What could be the problem?

$\endgroup$

marked as duplicate by CharlesL, Keavon, Gunslinger, iKlsR Jan 27 '14 at 13:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

34
$\begingroup$

As @gandalf3 pointed out, you can check out the answer here. I'll redo it with a bit more detail though.

I'll assume you've already UV mapped your plane (select plane, go into Edit Mode, U > Unwrap) and you already set up the texture in the Materials tab to look like this:

Materials settings

So, you render and the alpha appears as black.

enter image description here

To fix this, you go into the Node Editor and you use the alpha information to set where the plane should display the texture image and where it should have transparent material.

enter image description here

Render and you should have transparency.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ In blender 2.78 this works for me even without the leftmost "Texture Coordinate" node. $\endgroup$ – squarespiral Dec 6 '16 at 9:32
  • $\begingroup$ Perfect! Works great on fixing the hair and eyes that come out of makehuman. $\endgroup$ – phyatt Oct 31 '17 at 4:08
  • $\begingroup$ Make sure the "white" in Transparent BSDF is really "pure 100% white"! Also worked for me (Blender 2.80) if I just bypassed the Difuse shader and ran the color right to the mix shader instead. $\endgroup$ – Brad Sep 27 at 19:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.