2
$\begingroup$

When I drag the video file down from the files window, it brings in the video sequence and the audio with it, however, while all the audio loads in, the whole video wont, only about 80% ish of it would show in sequencer and there is more to load in because I watch the unedited footage and its right there. But it wont load into sequencer, I have tried hard cutting and deleting parts of the video sequence in case the amount was an issue, one small addition is the video is longer than the max amount of frames available for blender in the first place but this has never been an issue before as I have edited similar length videos as well.

$\endgroup$
  • $\begingroup$ The issue would be that the video is using a codec that blender can't decode. Can you get what codec is used by the video? What OS and blender version? $\endgroup$ – sambler Oct 1 '16 at 17:50
  • $\begingroup$ Codec is H.264 - NVENC (VBR), Windows 10, and Blender 2.77 I think, but why would codec restrict or stop the rest of the video sequence loading in, its pretty much only like another 20 mins missing, the rest loads in fine. $\endgroup$ – Dan Oct 1 '16 at 18:20
  • $\begingroup$ I thought none of the video was loading so expected a codec blender couldn't read. $\endgroup$ – sambler Oct 1 '16 at 18:57
  • $\begingroup$ It could be that Blender can't understand well video and audio frame rate so video and audio strip have different lengths, that happened in the past to me. But I can't understand how you could end with some missing part of a track... how long is your video, and what its fps? $\endgroup$ – m.ardito Oct 2 '16 at 10:45
  • $\begingroup$ The video is 03:11:00 (3 hours and 11 mins) long and is recorded at 30 fps, another minor detail which I didn't mention for some reason is that it is a game recording on screen, previous videos that I have edited have been just as long and have been recordings of gamming sessions and I have had no issues, the videos previously loading in completely but outside of the frame range, fro which I hard cut and deleted segments to make more room. But that isn't the case this time since the whole video isn't loading in. $\endgroup$ – Dan Oct 2 '16 at 10:56
1
$\begingroup$

I faced the same issue just now. You should use ffmpeg to re-encode the video, specifying a bitrate and forcing frames to be duplicated. This worked for me:

ffmpeg -i input.mp4 -c:v libx264 -preset ultrafast -crf 0 -c:a copy -r 30 -vsync cfr output.mp4

This will generate a huge file because it's not compressing the video at all; if space is an issue, you can play with the -cfr parameter, bringing it to 20 or so (higher numbers mean more compression).

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.