2
$\begingroup$

I'm trying to render a steel plate with the Anistoropic BSDF. I would like to have curved reflections as it happens in pans or pots (for cooking). Instead, when I render, I get this strange straight lines appearing on the plate surface, and I cannot get rid of them. As a source light I'm using two planes with emmision. Here are images of the case (with the plate nodes) and of the rendered image. I don't know it this can help, but it was created with FreeCAD. May be it can be related with the problem.

Here is the link to the blender file

Thanks all for you help.

David

case and nodes

rendered image

$\endgroup$
1
$\begingroup$

Here is the final fixed result:

enter image description here

Shading

You need to click on the Tangent menu in the material settings and select a Tangent node. Make sure Radial is selected it its settings. Play around with the Axes: to figure out which one to use.

enter image description here

Gandalf3's image from here.

Modeling

Your mesh is covered in triangles (not good). From the .blend file that I downloaded, this was my process:

  1. A twice to select everything.
  2. Alt + J converts many tris to quads.
  3. Ctrl + Tab, then 3 to enter Face Select Mode.
  4. Alt + RMB RMB while hovering over one of the edges around the outside rim to select this face loop:

enter image description here

  1. Ctrl + I to Invert Selection.
  2. X > Faces to open the Delete menu and delete Faces.
  3. Ctrl + Tab, then 1 to enter Vertex Select Mode.
  4. Alt + RMB RMB while hovering over one of the edges in the topmost edge loop to select this edge loop:

enter image description here

  1. F to create an N-Gon face.
  2. Ctrl + I to Invert Selection.
  3. F to create an N-Gon face.
  4. Tab out of Edit Mode.

Here is the fixed .blend file:

P.S.

This is not included in the .blend file, but if you want less spotty anisotropy, you should use these settings in the Properties panel > Render tab.

enter image description here

They produce this result:

enter image description here

$\endgroup$
  • $\begingroup$ Thank you for your reply Shady Puck, I tried what you said and effectively reflections seem to be radial. However the strange lines still are there. I noticed that smoothing the nodes the lines vary, so I guess they are related with the elements. However I still dont know how to solve the problem. $\endgroup$ – David S. Oct 1 '16 at 15:18
  • $\begingroup$ @DavidS. Can you upload your .blend file to Blend Exchange and edit your question with the provided link? $\endgroup$ – Shady Puck Oct 1 '16 at 15:30
  • $\begingroup$ @DavidS. See my edit. If this answer helped you, please consider marking it as accepted by selecting the checkmark in its upper, left-hand corner. It would help me greatly and make me very happy! $\endgroup$ – Shady Puck Oct 1 '16 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.