0
$\begingroup$

Kinda focusing on what is not working here, but hey, I noticed that Blender kind of downgrades my textures/paint-work ... it gets a bit pixelly after I switch to Object mode and then back to texture paint mode..

Maybe its just my impression, but it does seem to me as if the textures get kind of bland and pixelly after a while....

I am using 2048x2048 px res right now, too small?

Am I alone in this? May I prevent this somehow?

Would be really nice if my textures stayed nice and smooth the way I paint them....

$\endgroup$
  • $\begingroup$ Check your UV map to make sure there isn't a small area of pixels being mapped to a large surface area of the mesh. This could cause the sort of pixelation you describe, as the pixels would be stretched out and enlarged. $\endgroup$ – Mentalist Sep 30 '16 at 13:49
1
$\begingroup$

Blender doesn't change the textures in any way by itself and this applies to all possible actions.

The texture size does not necessarily define its quality, it depends on the source (image texture, procedural material, tiling, up/donwscaling...) but normally I'd say that everything from 1k upwards is fine.

You might want to check Blender's System Settings. Hit Ctrl+Alt+U, go to "System" and play around with the settings for "Mipmap" and "Anisotropic Filtering". Deactivating them seems to help in many cases.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.